Jump to content

sdarktemplar

Members
  • Content Count

    15
  • Joined

  • Last visited

Community Reputation

0 Neutral

About sdarktemplar

  • Rank
    Private First Class

Recent Profile Visitors

120 profile views
  1. Hi, Spec and status as below Toshiba R30-A System BIOS Version 4.80 EC Version 1.60 CPU Intel i7 4910MQ 2.9GHz RAM Samsung DDR3 1600 8G x 2 MB Chipset Intel HM86 SSD Intel 730 480G Audio Realtek ALC283 Graphics Intel HD Graphics 4600 Ethernet Intel Ethernet Connection I217-V WIFI/BT Intel Dual Band Wireless-AC 7260 Touchpad Alps TTP1000 SD card reader RTS5227 PCI Express Card Reader Camera TOSHIBA Web Camera - HD Working: Keyboard Ethernet Camera Sleep ExpressCard (working with Firewire Card) USB 3.0 x 3 Backlight control Not Working CPU (only working below 2GHz) CPU Fan (sometimes very noisy even cpu is idle) Battery Status Audio (no device detect) HDMI Touchpad (no multitouch, SysPrefs -> Trackpad is empty) WIFI/BT (I will change it to AW-CE123H) Please help! Thanks Regards, Yui Debug.zip
  2. sdarktemplar

    Latitude 5480 TB3 hot plug does not work

    Any help?
  3. sdarktemplar

    Latitude 5480 TB3 hot plug does not work

    Hi Thanks for reply. my IOReg and EFI as attachment. the USB3.0 and USB2.0 works fine no the TB15, only the USB3.1 typeC no hot plug Thank you EFI_IOReg_patchmatic_Termianl.zip
  4. Few days ago, I clean install the 10.13.1 on my 5480, and the usb3.1 type-c hot plug works fine. yesterday I got the Dell TB15 (TB3 dock), then TB3 is no hot plug, I have to plug in before boot, and the type-c on the TB15 is no hot plug, either. any idea? Thanks
  5. sdarktemplar

    Latitude 5480 (+ Geforce 930MX) need help for DSDT patch

    Hi Jack, Could you tell me the diff of your patch? thank you
  6. sdarktemplar

    Latitude 5480 (+ Geforce 930MX) need help for DSDT patch

    Hi Jack Lo I used the origin + hot plug SSDT + your new DSDT the hot plug does not work.
  7. sdarktemplar

    Latitude 5480 (+ Geforce 930MX) need help for DSDT patch

    @Jake Lo I try another ssdt.aml for USB3.1 type-c hot plug, your DSDT is not work either. I try this one http://www.insanelymac.com/forum/topic/319764-guide-dell-xps-15-9550-sierra-10122-quick-installation/?p=2473139
  8. sdarktemplar

    Latitude 5480 (+ Geforce 930MX) need help for DSDT patch

    @Jake Lo hi, before I use your DSDT, I add SSDT-TBON.aml get form here http://www.insanelymac.com/forum/topic/319764-guide-dell-xps-15-9550-sierra-10122-quick-installation/?p=2491739 and the USB3.1 works fine, include hot plug. Then I use your DSDT, the Sleep works, the USB3.1 works, but no hot plug. Could you check it for USB3.1 hot-plug? Thanks for your help! Regards, Yui
  9. sdarktemplar

    Latitude 5480 (+ Geforce 930MX) need help for DSDT patch

    2017-10-26 09:24:47.813753+0800 localhost kernel[0]: (AppleACPIPlatform) Wake reason: PBTN XDCI XHC (User) 2017-10-26 09:24:47.813755+0800 localhost kernel[0]: (AppleACPIPlatform) Wake reason: PBTN XDCI XHC (User) 2017-10-26 09:25:41.661414+0800 localhost kernel[0]: (AppleACPIPlatform) Wake reason: PBTN XDCI XHC (User) 2017-10-26 09:25:41.661415+0800 localhost kernel[0]: (AppleACPIPlatform) Wake reason: PBTN XDCI XHC (User)
  10. sdarktemplar

    Latitude 5480 (+ Geforce 930MX) need help for DSDT patch

    @Jake Lo Nothing, I use the origin DSDT/SSDT to boot, it just native work.
  11. sdarktemplar

    Latitude 5480 (+ Geforce 930MX) need help for DSDT patch

    @Jake Lo Thanks for your replay. The reason why I use the origin DSDT/SSDT is the USB 3.1 will work(connect before boot, no hot plug) ( the config.plist is base on this https://github.com/RehabMan/OS-X-Clover-Laptop-Config/blob/master/config_HD615_620_630_640_650.plist ) or could you check the USB3.1 with attachment #2 and #4, maybe it will be more easier to let them all work? thanks for your help!
  12. sdarktemplar

    Latitude 5480 (+ Geforce 930MX) need help for DSDT patch

    @Jake Lo Something update I del all the DSDT/SSDT in /E/C/A/P get from 5480_BIOSv1.zip, and patch origin DSDT/SSDT which get from /E/C/A/O Progress as below: Working: Keyboard Headphone Microphone Speaker Ethernet Camera USB 3.0 x3 Brightness Keys USB.3.1 type C (Plug in before boot will work) Geforce 930MX (Disable successful) Not Working(sort by priority) Sleep HDMI (some monitor do not detect hot plug, no HDMI audio) Pending Thunderbolt 3 (waiting for TB3 device to test) WIbFI/BT (waiting for DW1560) Touchpad (No Driver) SD card reader (No Driver) SmartCard reader (No Driver) Give up VGA Could you help me patch the DSDT for Sleep? It will waked immediately when just sleep, there is no battery and power adapter in Energy Saver as below: EFI folder, IOReg and some kext information get from terminal is compress as attachment. Thanks for your help, Regards, Yui Archive.zip
  13. sdarktemplar

    Latitude 5480 (+ Geforce 930MX) need help for DSDT patch

    I replace the DSDT.aml, but the 930MX is still enable as below 7. Add FakePCIID_Intel_HDMI_Audio.kext and FakePCIID.kext to /S/L/E/ Result: HDMI audio still no luck, speaker and headphone become no sound, but I could see it in the System Preferences/Sound. Mic is work, I could use Audacity record sound, but could not to play. 8. Add VoodooI2C.kext to /E/C/K/O/ and remove AppleIntelLpssI2CController.kext, AppleIntelLpssI2C.kext, and AppleHPM.kext from /S/L/E/ Result: Only Touchpad’s button work. Before check the DellSMBIOS patch result as below After check it as below Yui’s MacBook Pro_5480_Disable930MX_Yui_config_1710221334.zip
  14. sdarktemplar

    Latitude 5480 (+ Geforce 930MX) need help for DSDT patch

    @Jake Lo Thanks for your reply. Let me tell you what I do after follow the guide, I use the EFI_4250.zip and 5480_BIOSv1.5.2.zip to install the 10.12.6 Update Clover to v2.4k_r4257 Remove all kext from /E/C/K/O/LE in /S/L/E/ Remove ApplePS2Controller.kext Add VoodooPS2Controller.kext in /E/C/K/O Result: Keyboard fixed Update Lilu.kext, to /E/C/K/O Update AppleALC.kext to /E/C/K/O cp CodecCommander.kext to /S/L/E/ and rebuild kernel cache Result: Speak and Mic fixed Remove RealtekRTL8111.kext from /E/C/K/O Remove IntelGraphicsDVMTFixup.kext from /E/C/K/O Remove SATA-100-series-unsupported.kext from /E/C/K/O Remove IOAHCISerialATAPI_Injector.kext from /E/C/K/O Update FakeSMC.kext Update IntelGraphicsFixup.kext to /E/C/K/O Modify DSDT.dsl as below Remove AppleIntelSKLGraphicsFramebuffer in KextsToPatch Add AppleIntelKBLGraphicsFramebuffer replace 02040a00 00080000 87010000 03060a00 00040000 87010000 ff000000 01000000 20000000 to 01050900 00080000 87010000 02040a00 00080000 87010000 ff000000 01000000 20000000 Change SMBIOS to MacBookPro14,2 and check DellSMBIOSPatch Result: HDMI work but without sound Status as below Working: Ethernet Camera USB 3.0 x3 Battery Sleep Speaker Microphone Keyboard Brightness Keys HD630 & HDMI Not Working Thunderbolt 3 (only show “Thunderbolt: No hardware was found.” in the system report) USB.3.1 type C (if I plug the type-c external HD before boot, it will show something in the system report) HDMI Audio Touchpad Headphone (buzz) SD card reader SmartCard reader Geforce 930MX VGA WIFI/BT (I will change it to DW1560) I use the DDST, SSDT and config.plist, But the HDMI become does not work, and I could still see the 930mx in the system info. So I attach two IOreg files which use yours and my config.plist Archive.zip
  15. Hi, I follow these guide to install 10.12.6 https://osxlatitude.com/index.php?/topic/8506-dell-latitude-inspiron-precision-clover-guide/ https://osxlatitude.com/index.php?/topic/10014-latitude-5480-keyboard-and-trackpad-not-working/ Spec as below: BIOS Version 1.6.3 CPU Intel i7 7820HQ RAM Kingston DDR4 2400 16G x 2 MB Chipset Intel CM238 SSD TOSHIBA THNSNK256GVN8 M.2 2280 256GB Audio Realtek ALC3246 Graphics Intel HD Graphics 630 + NVIDIA GeForce 930MX Ethernet Intel Ethernet Connection I219-LM WIFI/BT Intel Dual Band Wireless-AC 8265 Touchpad ALPS I2C touchpad Thunderbolt 3 Controller Intel JHL6340 SD card reader Realtek PCIe SD Card Reader SmartCard reader Broadcom 5880 USB PCSC Camera Realtek 720p HD Camera Working: Keyboard Audio: Speaker, Microphone, Headphone Ethernet Camera USB 3.0 x3 Not Working(sort by priority) Thunderbolt 3 (only show “Thunderbolt: No hardware was found.” in the system report) USB.3.1 type C (if I plug the type-c external HD before boot, it will show something in the system report) HDMI Sleep Brightness Keys Touchpad (only button works) HD630 (show Intel HD 620 1536 MB in about this Mac, else is fine I think) SD card reader SmartCard reader VGA Geforce 930MX WIFI/BT (I will change it to DW1560) Please help me to patch the DSDT, I need tb3 for eGPU, and if hackintosh doesn't support 930MX please disable it for power consumption, thank you very much! EFI & IOReg.zip
×