Jump to content

[SOLVED] Installing el capitan bootloop e7240


Mariotaf
 Share

Recommended Posts

Hi.

I got recently a e7240 with i5-4310U

I followed the guide and used e7440 bootpack but when I click on " boot macOS from Install OS X El Capitan " in Clover boot manager, the apple logo appears and the pc reboots again and go back to the same menu.

Can someone advice me.

Thanks

Os x el capitan 10.11.2

Link to comment
Share on other sites

  • Moderators

When you install Clover (latest version 4184), the EFI partition is mounted, or use EFI-mounterv3 attached in the guide. It's all listed in the post installation.

For audio did you following the post guide?

7. Copy kexts from /EFI/Clover/Kexts/Other/LE to /Library/Extensions of Macintosh SSD

    Note: Ignore warning/error messages and click OK, then run commands below.

 

8. Repair permission and rebuild cache. Run command from terminal

 

      sudo chmod -Rf 755 /L*/E*
      sudo chown -Rf 0:0 /L*/E*
      sudo touch -f /L*/E*
      sudo chmod -Rf 755 /S*/L*/E*
      sudo chown -Rf 0:0 /S*/L*/E*
      sudo touch -f /S*/L*/E*
      sudo kextcache -Boot -U /
 
No multitouch, just 2 fingers scrolling, 2 fingers right click and tap to click. The animation in the touchpad is emulating a real Mac, most functions don't work.
Link to comment
Share on other sites

So I restart again to check what's wrong.

I get this log when I fix permission

MacBook-Air-de-Mario:~ mario$ sudo kextcache -Boot -U /

rebuilding //System/Library/PrelinkedKernels/prelinkedkernel

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext EAPDFix.kext

kext file:///Library/Extensions/DisableTurboBoostBattery.kext/ is in hash exception list, allowing to load

kext-dev-mode allowing invalid signature -67062 0xFFFFFFFFFFFEFA0A for kext CodecCommander.kext

File at path '/System/Library/PrelinkedKernels/prelinkedkernel' changed, cannot be used

Child process /usr/sbin/kextcache[1311] exited with status 77.

Error 107 rebuilding /System/Library/PrelinkedKernels/prelinkedkernel

 

And still no sound

Link to comment
Share on other sites

  • Moderators

Not seeing AppleHDA_ALC292.kext in the output above. Rerun this command until error 107 is gone

sudo touch -f /L*/E*

          sudo touch -f /S*/L*/E*
          sudo kextcache -Boot -U /
 
Reboot and rerun if output still not showing AppleHDA_Alc292.kext
Link to comment
Share on other sites

I've done what you said but it returns

Kext-dev-moded allowing invalid signature for EAPDfix.kext ant CodedCommander.kext

And

Kextcache updated critical boot file, requesting launchd reboot

 

I've tried to reboot and rerun the commands several times but still the same

 

Other point, I copied EFI folder from the usb installer, to the EFI partition of the installed disk and edited clover option for this disk but when I reboot the screen stay black and nothing. I can boot only with clover from the usb

 

And another, why I don't have *.aml with ssdtPRGen.sh? Only ssdt.dsl

Log :

Bugs > https://github.com/Piker-Alpha/ssdtPRGen.sh/issues <

 

System information: Mac OS X 10.11.2 (15C50)

Brandstring 'Intel® Core i5-4310U CPU @ 2.00GHz'

 

Scope (_PR_) {220 bytes} with ACPI Processor declarations found in the DSDT (ACPI 1.0 compliant)

Generating ssdt.dsl for a 'MacBookAir6,2' with board-id [Mac-7DF21CB3ED6977E5]

Haswell Core i5-4310U processor [0x40651] setup [0x0605]

With a maximum TDP of 15 Watt, as specified by Intel

Number logical CPU's: 4 (Core Frequency: 2000 MHz)

Number of Turbo States: 10 (2100-3000 MHz)

Number of P-States: 23 (800-3000 MHz)

Adjusting C-States for detected (mobile) processor

Injected C-States for CPU0 (C1,C3,C6,C7)

Injected C-States for CPU1 (C1,C2,C3)

 

IASL not found. Downloading iasl...

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0curl: (6) Could not resolve host: raw.githubusercontent.com

chmod: /usr/local/bin/iasl: No such file or directory

Done.

sudo: /usr/local/bin/iasl: command not found

Do you want to open ssdt.dsl

Link to comment
Share on other sites

 Share

×
×
  • Create New...