Jump to content
spidey123

Trying to generate SSDT with ssdtPRgen

Recommended Posts

Hi guys, it's been a long time since I generated my own ssdt via pikers script.   So after I installed HS today, I noticed some overheating issues on my latitude.  Anyhow I tried to create a new ssdt but I get error messages.   I'm not sure whats going on.

 

grep: /Users/xxx/Library/ssdtPRGen/ACPI/SSDT*.aml: No such file or directory 

Error: /Users/xxx/Library/ssdtPRGen/ACPI/DSDT.aml not found!
Aborting ...
Done.
 
So I understand that error one means there is no SSDT*.aml in the directory and that is correct.  
 
Am i suppose to place an original SSDT dumped from my computer here? Because if yes I will need to dump it again during boot as I don't believe I have a saved original since I was using a generated one with the earlier piker script.
 
And the second error I can also understand because inside of the ACPI folder there isn't anything there either.  
But of course I have it in my EFI drive inside /clover/acpi/patched
So what I'm not understanding is why are those errors coming up?  And how do i fix it? 

 

So basically Im just trying to figure out how to generate a new SSDT for HS, instead of using my old one.  Just to see if that resolves some of the overheating issues i'm experiencing.

 

 

Share this post


Link to post
Share on other sites

Copy the folder ssdtPRGen.sh-beta to ~/Library and rename it to ssdtPRGen

run in terminal

cd ~/Library/ssdtPRGen
./ssdtPRGen.sh

answer no and no. 

copy the generated SSDT.aml to /EFI/Clover/ACPI/Patched

Share this post


Link to post
Share on other sites

Ok that was much easier then I expected.  Thanks Jake Lo.  I actually already had a folder named ssdtPRGen there and I guess it had older files from the previous scripts???  Anyhow not sure if I can erase it or not so for the time being I just renamed that folder and brought in the newer ssdtPRGen folder and the script worked perfectly now.  Thanks Jake Lo.

 

 

P.S  I forgot to mention one thing, do I still put -turbo 3300 after script command?  Or run it as is?  I actually tried both ways and the output for each read the same, so I'm assuming the script knows which chipset you have automatically now.

Share this post


Link to post
Share on other sites

Ok so after a bit of experimenting, I found both are identical and both have the same issues.  The battery status is not updating properly.  In fact i doesn't update at all.  What ever the battery % is at when you turn it on is where it stays.  It also doesn't update if you unplug it from the outlet.  

 

However the ssdt that I was using with Sierra still works for that.  In fact I've switched back to it because the slighlty overheating issues remain the same.  

 

Wonder if there is something missing in my config.plist   I was reading that with Sandy Bridge cpu's that need to have AsusAICPUPM=true in clover config.  I just looked an I actually don't have that kext in my Kext's folder nor do I have the patch entered in my config.  I have this instead

 

<key>AppleIntelCPUPM</key>

<true/> 
 
 

 

 So not sure if that is one of the issues or not.  For the time being I will continue to use the older SSDT that worked with Sierra.  On intial boot, the temps in HWMonitor go as high as 84-85 for a second or two then slowly come back down.  As I'm wriing this I'm at 52-54* degrees for all three (Cpu Cores 1-2 and Cpu Package)  So its pretty much where I was with Sierra.  The extra overheated may have been the result of more workload do to installation process.  That's what I think because one I let the computer cool down for a bit I didn't reach the 86-92 degree anymore.  

 

 

What does the team think?  Should that entry be placed back into Kexts to patch on the fly section of the .config?

Share this post


Link to post
Share on other sites

AH ok Bronxteck :)    Ok so at least I have figured out how to refresh the battery status.  I need to go to "Show Battery percentage" on the top menu and then click it on and off and it will refresh to current %.  This is the same if I use the old SSDT that I was using in Sierra or the new one I just generated today.

 

Might have to add a new patch to my DSDT for proper battery status in HS.  I'll wait to see what I can find out and I think it's best to start a new thread for this topic as I bet others are also having the same issues on High Sierra.  Have you noticed this at all on your Latitude?

Share this post


Link to post
Share on other sites

  • Our picks

    • [SUCCESS] DELL LATITUDE E5440 - High Sierra 10.13.2 [UEFI]
       What Works / Does Not Work: Everything works except the built-in Intel WiFi wireless network card.
      NOTE: The NVIDIA GT 720M, specifically the external graphics card, is completely disabled (on MacOS).
      • 2 replies
    • Welcome to OSXL! We are looking for volunteers to join us!
      Welcome to OSXL! 😀
       
      We, at OSXL, are a bunch of passionate Hackintoshers who have joined together for creating a community to drive learning, sharing and helping people interested in running Apple Mac software or tinkering with it on non-Apple hardware. We do research and development on a voluntary basis in our free time.
       
      Since its inception in 2010, our team evolved with people joining and going for all sorts of reasons. Nevertheless, this team brought out some of the best people who contributed to making the Hackintosh community progress. Unlike some other players, we’re very proud to we have consistently offered an ad-free website without calling for financial support, except on very rare occasions, and also made one of the best looking sites.😍 
       
      Back in the days, we also designed our "EDP" project to provide a common OS X installation package and a unified post-installation tool. EDP basically offered a central hub for system tuning. The project went through several phase and the latest one is currently Work In Progress. We also completed some research work and developed drivers, fixes and patches for some hardware.
       
      We recently revamped our site to a more modern look and implemented latest security features so to give our members an improvise quality of experience.
       
      Also, we are looking to expand for diversifying the content on our site not only to Apple OS, but also Linux, Android and Windows in the very near future with research and development as tech industry has changed a lot recent years and there is so much we can do in other areas and be relevant to what we do. 
       
      We are looking for passionate and dedicated people who can invest time and efforts in our community on projects like EDP and many others. 
       
      Drop us a line here in comments or through PM if interested so that we can chat about motivation, skills and ideas.
       
      You can find our crew list here if you would like to PM instead: OSXL Crew
       
      OSXL
       
        • Like
      • 0 replies
×