Jump to content

Latitude E5440 High Sierra Upgrade using Clover


Recommended Posts

Doh! Of course. APFS is the issue. Will keep HFS+ on this laptop. Thanks!


But unfortunately i am gettinng same error. Is it because the helper got installed for APFS? How do i remove it? Thinking it is still trying to use APFS and so trying to format my partition. If HFS+ was taken then it will simply copy High Sierra files.


At least I think this is the issue, else I dunno what to do now. This laptop will only take slim SSDs and I'm fresh out of them. So have to fix this SSD and make it work.

Link to comment
Share on other sites

Hi Jake, I googled my way to remove the install menu item from HS, then relaunched using no APFS, however I still get the same error.


One thing I did notice that is diff from my other dual boots with Enoch is I don't see "Recovery HD" menu item with Clover. Googling seems to indicate this is the issue and I need to repartition my Macintosh Partition in order to create a Recovery partition. Assuming this will fix my problem trying to figure this out right now. Meanwhile could use some advice. Simultaneously almost wondering if should simply create USB for HS and use your pack again, but worried in case it converts to APFS and that's not good for dual boot.


Another issue is v4220 seems to have killed my sound and brightness keys (FN + F3/Pause). This is the symptom where I do get the volume control enabled after I repair permissions however it still does not produce any sound. However, this can wait till later.

Link to comment
Share on other sites

Thanks Jake! I will try the link for creating recovery drive first.


If I mess up and have to reinstall, I will just start from scratch and use your pack. I believe there is a way to intercept APFS converstion when installing from scratch so I could try that so I can dual boot again. Not sure if APFS will prevent dual boot.


Instructions very well documented here...



Unfortunately still get same error.


Error (async): This partition map modification would make a Windows partition unbootable (-69728)


So I guess my only hope is to reinstall? :-(


PS - I used GParted to shrink my Mac OS partition to leave some free space before the Windows began, but it still will not create recovery partition there. :mad:.

Link to comment
Share on other sites

Jake, Herve, All, need some advice.


This laptop will only take a slim SSD. I dunno if there are slim HDs out there. Regardless, it does not look like I will be able to overlay High Sierra. So while I can do a scratch install since it is SSD, it will default to APFS and then I can't do dual boot with Windows. Wanted to ask if either of the two options are viable.


Option A

1) Find a HD with exact same size as the SSD. Connect it through USB enclosure and clone my Sierra Mac Partition only onto it.

2) Remove the SSD. Upgrade High Sierra inplace on the HD which will only have Windows and thus I should not hit the problem I've been hitting.

3) Restore HD partition back onto SSD partition.


Option B

1) Delete Windows partition on SSD

2) Let High Sierra upgrade take place.

3) Partition SSD again and try reinstall Windows now (will this work?)


Thanks much.

Link to comment
Share on other sites

Herve, I think you are suggesting I just reinstall 10.13 from scratch? I'm worried I will hit the same problem as long as I have windows on the other partition. I guess time to cut my losses even if that's the case and basically re-do entire dual boot install. Thanks!

Link to comment
Share on other sites

Okay I don't get this. I built Clover USB from scratch and booted from it. Problem is it never even asked me to select language screen. Instead it went directly to installing High Sierra and gave me same error.


Seems to me I simply have to format entire drive before attempting install. As long as I have Sierra, High Sierra is simply going to try to upgrade regardless of what I do.


So I decided to install to drive connected to eSATA. Now I get an error saying OSInstall.mpkg file is missing. I built the USB twice following instructions. Ive done this so many times I'm not making a mistake.


I guess I just need a break here. I'm going to wait until someone publishes a guide for installing 10.13 from scratch.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...