Jump to content

E7450 with High Sierra: WiFi/display/audio/etc. not working


rstmp101
 Share

Recommended Posts

currently couple things not working

- wifi DW1560 

- display scrambled , till sleep, restart

- sound not working

- DisplayPort not working,  HDMI port works

 

notes:

- can I copy my el capitan on second partition to boot, with current r4359 clover ?

that would be a great help

- looks like lilu is not working

 

E7450 i5-5300U , A17 bios

- unifail install,  high Sierra 10.13 , multifail , clover r4359, 

- dsdt.aml, ssdt, from bootpack E7450_HD5500_Only_A17_HS.zip  

- currently MacBook Air , ssdtprgen says it's mismatch, should be MacBook Pro 12,1

 

appreciate any help, pointers 

- rules -> what does TMX stand for ?

 

--

Latitude E7450, BIOS A17 | i5-5300u  2.6 GHz   | 16GB DDR3 | Intel HD 5500, 1920x1080 | Replaced Dell DW1560 | El Capitan | Clover r3911 | Sleep, Yes

 

desktop quad , Sierra 

config.plist.zip

  • Like 1
Link to comment
Share on other sites

  • Moderators

See here regarding wifi

We don't support TMX (tonycrapx) stuff here so if you're using it ( unifail/mutifail), then you should ask for support there.

Since you're using my files, you should include the kexts folder as well to have audio, graphics, wifi ...working.

Kexts in ../kexts/Other/LE should be moved or copy to /Library/Extensions

Run permission fix and rebuild cache afterward

 

Dual boot should be supported...

Link to comment
Share on other sites

thanks Jake! 

 

update notes:

- Wifi                - Works now

- Bluetooth      - not working now

- sound            - not working

- DisplayPort   - not working

- laptop display -> works after sleep wake

- copied HS on second partion, and EFI r4359, -> does not see El Capitan partition. 

 

- did try config.plist from bootpack E7450_HD5500_Only_A17_HS.zip --> got KP

​- did try install , vanilla clover r4359  -> got no boot entries

 

next

- I will trim back my current config.plist down to match  the bootpack config.plist 

- ssdt.aml, create new (ssdtprgen.sh) , for macbook12,1 since processor does not match with MacBook Air7,2 from bootpack

 

have no idea ,

- how you guys install from scratch, did not see it in the install guide

- or install vanilla clover , with boot entries

 

% sudo kextcache -I /

hope that does the trick doing the kextcache update and permissions fix

 

 

... sorry old noob at play, thanks

Link to comment
Share on other sites

update

- sound - working 

  -> copied AppleHDA_ALC293.kext /Library/Extensions 

 -> chmod, chown +  sudo kextcache -I /

-> note bootpack does not have AppleHDA_ALC293.kext. in bootpack kext/LE directory

 - instructions -> Audio with patched AppleHDA -> little vague for a noob

 

interesting, after all 293 patch,  the sound on monitor over HDMI disappears 

 

- laptop screen , still scrambled , till sleep/wake,  looks like LiLu , IntelGraphicsDVMTFixup.kext thing is not working from clover 

- Mini DisplayPort not working 

- have not tried docking station

Link to comment
Share on other sites

thanks Jake,

 

did  

--> Kexts in /EFI/Clover/kexts/Other/LE should be moved or copied to /Library/Extensions. Then repair permission and rebuild cache.

 

need to figure out IntelGraphicsDVMTFixup.kext  ,and scaled screen  after boot

 

-> looks like max freq is 2.2GHZ 

 does not look it ever gets to 2.7ghz turbo

 

post your E7450 Geekbench 4

and check with intel power gadget 

 

it be nice if the displayPort would work again , since the HDMI is not going to do 4k

 

attached files

bdmesg

Geekbench 4

intel power gadget 

config.plist

etc

post-63449-0-62579600-1515033440_thumb.png

post-63449-0-18938100-1515033452_thumb.png

bdmesg_rs_hs_10.13.log.zip

E7450_HS_MacBookAir7,2 - Geekbench Browser.pdf

post-63449-0-66676400-1515033802_thumb.png

post-63449-0-61667100-1515033813_thumb.png

post-63449-0-94780700-1515033826_thumb.png

post-63449-0-41695100-1515033838_thumb.png

config.plist.zip

post-63449-0-38047600-1515034239_thumb.png

post-63449-0-18458500-1515034665_thumb.png

Link to comment
Share on other sites

  • Moderators

Made a mistake on DSDT, bootpack is now updated.

Had HDEF/HDAU layout-id 1 on DSDT and 11 on Config.plist, it's now sync'd.

New bootpack uses Lilu + AppleALC for audio

Remove AppleHDA_ALC293.kext from /L/E

Repair permission and rebuild cache

 

This should fix the HDMI/DP audio

If you're going to generate SSDT for MBP12,1, make sure you change SMBIOS in Config file first.

Then reboot before generating.

  • Like 1
Link to comment
Share on other sites

still can't find it.

relevant guide for me 

 

Dell Latitude E7450 - Clover UEFI Only

 

https://osxlatitude.com/index.php?/topic/8514-dell-latitude-e7450-clover-uefi-only/&do=findComment&comment=54665

 

bottom of page, from dec 2017

Bootpacks

zip.gif  E7450_HD5500_Only_A17_HS.zip   3.38MB   3 downloads

 

note:

- running high Sierra 10.13

- bootpacks , don't show , date posted

- searching forum, only returns posts , not files updated

- searched posts, did not find any new posts on E7450

- do not see any revision or date on bootpacks

- even your profile, does not show , files updated, or a post, where a bootpack has been updated.

 

 sorry, just can't find it.

 

appreciate your support, thanks you !

time to donate via (PayPal) 

Link to comment
Share on other sites

 Share

×
×
  • Create New...