Jump to content

[SOLVED] HELP with E7270--not recognizing internal drive


xleech
 Share

Recommended Posts

My system is E7270, i7 6600, 256 Intel SSD (not NVME),  installed memory 8. Non touch, 1366x768, video memory 64mb.  BIOS 1.17.5  DVMT not modified.. using the Intelgraphicsdvmtfixup.kext

 

I have tried installing with both Sierra and High Sierra installers, using the boot packs from the update page.  I kept getting kernel panics with Sierra, so I moved on to High Sierra using the E7270_1175_HS bootpack and Clover v 4369. With High Sierra installer, it loads to the first screen with the Apple logos (after several screens with lots of error messages).  About half the time, the screen goes black after a minute, and nothing happens.  The other times, it gets to subsequent pages.  When I open the disk utility,  it does not recognize the internal drive.  Only the external installer USB is recognized.

 

I have tried the following, with no success: I replaced ACPI/origin/ with my own (clover F4), updated the Lilu and its plug ins to the current version, tried loading without DSDT, as suggested in another posting.

When I boot up with Ubuntu, it has no trouble seeing the hard drive.

 

I would appreciate your help.

 

Attached is my own ACPi/origin folder.

 

 

Link to comment
Share on other sites

Thanks to your guidance and reworked files, I have been able to install Sierra 10.12.6 to my internal hard drive and make great progress.  I am faced with a few problems I would appreciate getting advice..

1. When I shut down from the menu, it promptly restarts.  The only way I can shut down is hold the power button down.

2. No audio. BIOS says its audio is ALC3235.  I am using applehda_alc293.kext from the bootpack.

3. Trackpad works (simple gestures, no multitouch). However trackpad in syspref does not show a trackpad.  No trackpad. waiting for bluetooth trackpad.

 

attached is my current clover file and a list of debug reports.

 

 

CLOVER.zip

debug_24400.zip

Link to comment
Share on other sites

  • Moderators

Make sure you disable Legacy Option ROMs in BIOS, I think that's the cause of restart issue.

Replace the DSDT with attach to fix audio.

Need to remove AppleHDA_ALC293.kext

Move AppleALC.kext to /EFI/Clover/kexts/Other. Don't have it in /L/E

Remove FakePCIID_XHCIMux.kext from /L/E, not needed

Remove FakePCIID_Intel_HDMI_Audio.kext, don't need it

Included PS2 kext only work as generic mouse, you could try this for Alps

Repair permission, rebuild cache and reboot

DSDT-fixAudio.zip

Link to comment
Share on other sites

 Share

×
×
  • Create New...