Jump to content

E7450 Issues (Graphic Glitch, Battery Indicator) [10.13.3]


Recommended Posts

I also notice the debug folder does not have the IOREg file but a text file, hard to read through that. While running the debug script, do not do anything until it's finish. It suppose to download the IORegistryExplorer.app and extract the file. If it still fails, then try downloading this IORegistryExplorer_v2.1.zip save, compress and attach the file

A generic log in dumped by gen_debug if the IOREG dump fails after increasing the save times thrice. There could be various reasons for that. Maybe user has some fancy files/folders (files that are not really AML opcode but are in AML format) in CLOVER/ACPI/patched (this is one known issue)


However, I can see user saying:

The debug folder has no IOREG as the script failed to create it (permission failed). If have now attached one in the OP.

FaserF, could you please send me a screenshot of what happens when it (gen_debug) tries to dump an IOREG. Maybe I could then work on fixing it.



Link to comment
Share on other sites

@Jake Lo

Thank you already so much for your help. I will upload a new IOReg tomorrow or that day after tomorrow (don't have my Hackbook at me right now).

At the moment I have a new problem, my macos will sometimes not boot at all, it freezes at the beginning (always near HID: Legacy Shim..., But not always at the exact same line), I will attach a photo at the OP. Do you have any idea?


@black.dragon74 sure, I will upload a screenshot to you the next days, for now: it starts the IOReg, then trys to save it but macos tells an error that I have no permission to save it. It tried it for three times and failed. Once I downloaded the tool by myself everything was working.

Link to comment
Share on other sites

Sorry for answering that late.

I have now attached the files in the original post you have asked for.

Hope that I have now everything attached that is required.


@@black.dragon74 I have used your script today again and now it worked without any issue.

  • Like 1
Link to comment
Share on other sites

my issue reappeared. I have deleted the ssdt.aml which I had generated. Now my hackbook still sometimes dont wants to boot.

And when it boots I have to close and open my hackbook to see anything. So the same issue as it was in the beginning.

If i boot with the settings mentioned in #6 everything boots fine.

Has somebody any idea where the issue is?

Plugin Type is set to 1

Link to comment
Share on other sites

Not to scare you, but I work computer repair and I have seen machines newer then haswell have issues with "sleep wake"


The issue can really be seen in windows 10/8 - when you put the machine to sleep, then wake the machine it will have a pixelated screen and mouse. This is caused by failed parts of cache on the CPU AFAIK. 


Not sure if macos vs windows would make a difference if a system has this problem, but if you try installing Linux (we've tried ubuntu only) it'll also have this sleep wake issue, but in weird ways vs windows. With windows its very obvious. 


Search google "pixelated screen after sleep" for examples of this. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...