Jump to content
PayPal donations: [email protected] ×
Ardman78

E6530 NVidia Audio issue - Sierra

Recommended Posts

I've managed to get a clean install of Sierra working but have not managed to get a few hardware issues sorted out.  The biggest is the audio.  As soon as I install the audio kext and reboot, I get artifacts all over the screen.  This doesn't happen when the kext is not loaded.  

 

My spec:

 

Dell E6530 Latitude

Intel 4000/NVS5200 Nvidia

16Gb RAM

i7 

 

Any pointers would be great.

Share this post


Link to post
Share on other sites

Follow instructions from here to debug issue

gen_debug -sysprofile

 

Are you running with Optimus enabled or disabled?

If enabled, then you need to use BIOS A13, no higher. Known artifacts issue with higher versions of Bios.

  • Like 1

Share this post


Link to post
Share on other sites

Hi Jake

I am running with Optimus enabled and everything is great until I install the Apple IDT kext into the Library/Extensions folder.  However, I since found your HD4000 and Optimus pack and found a AppleHDA kext in there.  I've put that in my kexts folder and the audio is working without the artifacts, so thank you :)

 

Now, just need to get the Webcam working.

Share this post


Link to post
Share on other sites

I just tried to update Sierra via the App Store and whilst it appeared to install correctly, I got stuck in a kernel panic boot cycle.  I reinstated my EFI folder that I backed up before the update and no different. :(  Won't be installing the update again.

Share this post


Link to post
Share on other sites

Urgh, I got the webcam working thanks to another post on here and now my artifacts are back.  Everything seems to still be working but the graphics is a little frustrating.  I've tried disabling Optimus in the BIOS and I'm running A13.  Any other ideas?

Share this post


Link to post
Share on other sites

IF you have BIOS over A13 prior, you need to downgrade to A03, then upgrade to A13. Disabling Optimus, Nvidia 5200m so far is not supported. So you need Optimus enabled to use HD 4000.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...