Jump to content
brousseau6933

Dell Optiplex 9020 - High Sierra - Sleep/Wake

Recommended Posts

Hello,

 

I've post in a few threads about this last week but maybe it's better to have a dedicated one for this.

 

In short, it looks that all possessors of 9020 have KP when trying to wake the computer. So, sleep is useless in HS.

 

On my side, I asked on InsanelyMac for a tailored DSDT and even with that, the bug is not solved.

 

So, if you are an Optiplex 9020 owner running HS with sleep working, please share your config with us.

 

My system: Optiplex 9020, i7-4770, 16 Gb of 1600 MHz Hynix RAM, Asus GT 710. Running Sierra on a Samsung EVO 850 500 Gb, Windows 10 on a Silicon Power 128 Gb SSD. Also a WD hard drive 1 Tb for data and Carbon Copy Cloner. Others: Lacie D2 USB3 3 Tb and a Samsung T5 portable SSD 500 Gb, these two connected on an Orico PCIe 2x USB 3.1 card (and yes, Sierra run this card natively in USB 3.1 Gen 2 speed for the T5, 10 Gb/s!).

 

Everything is working like a real Mac in Sierra: sound, sleep, iTunes movies, iMessage, CPU power management, etc...). I also use an external USB audio interface (Roland Octa-Capture) for studio duties.

 

Clover version is 4380.

 

Thanks for listening and thanks for the help I've got here...

 

Patrice

Share this post


Link to post
Share on other sites
6 hours ago, Jake Lo said:

Clover generic EFI here

and bootpack here, goes into /EFI/Clover

Thanks Jake

 

I tried with your clover.

But I got the failed screen.

I attached my efi folder and failed screenshot.

My system:

Optiplex 9202, i5-4570, 12 Gb of 1600 MHz RAM, 500Gb SATA, Intel HD 4600 1536 MB, BIOS A05

 

El Capitan and Sierra were worked in my PC but not High Sierra

What is wrong in my side?

 

Regards

 

EFI.zip

IMG_0033.jpg

Share this post


Link to post
Share on other sites

Update your BIOS to latest

Are you connected through DisplayPort?

VGA won't work.

Share this post


Link to post
Share on other sites
5 minutes ago, Jake Lo said:

Update your BIOS to latest

Are you connected through DisplayPort?

VGA won't work.

Sure I connected through DP

and I am going to update the BIOS.
Then could you let me know how to update the BIOS?

 

I am using Sierra for now.

 

Thanks

Share this post


Link to post
Share on other sites

Create a bootable USB (WinPE). Download the latest BIOS update to the USB. Boot with the USB and execute the file.

Or if you have Windows already running, download the update and run it from there.

Share this post


Link to post
Share on other sites
24 minutes ago, Jake Lo said:

Create a bootable USB (WinPE). Download the latest BIOS update to the USB. Boot with the USB and execute the file.

Or if you have Windows already running, download the update and run it from there.

Thanks Jake

 

I updated the BIOS version to A22.

But unfortunately, I am still getting failed screen.

 

Any other option?

 

Regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×