Jump to content

7480 no touch pad


Liem Vo
 Share

Recommended Posts

Hello,

 

I've successfully install High Sierra on E7480 i7600U. But the touchpad does not working, i've tried VoodooPS2, Redefined ALPS kext, VoodooI2C but none working.

Also i have problem with Apple backlight, i can only adjust brightness after sleep/wake (It immediately wakes after sleep a few seconds)

Audio ALC256 not alway works, sometime not working after restart.

 

 

Thanks in advance

debug_19438.zip

Link to comment
Share on other sites

I'm able to make the touchpad work by copy the VoodooI2C kexts to /L/E, remove AppleI2C kexts and use GPIO pin 0x0000. But It now just like a mouse, how to make the 2-3 fingers gestures works?

Also i have problem with sleep, it wake immediately after sleep a few seconds.

debug_2482.zip

Link to comment
Share on other sites

My touchpad work on boot and after wake, the GPI0 is 0x0000

I've tried I2C Controller patch by Coolstar but not work for me. On boot it stuck at:

 

AppleIntelLpssI2CCController::_servingMatchingTimeSubr: fTimeServiceMatching timed out, fNotifications 0

 

I removed Apple I2C kexts then work fine.

 

Almost everything worked on E7480, except some minor issues:

- Weird sound lost, if it lost i have to restart 2 times and it works again

- Brightness adjust only work after sleep / wake

- Touchpad multi touch gestures, VoodooI2CSynaptics not support yet

- If HDMI plug in and close the lid, instead of sleep all window transfer to HDMI monitor and laptop screen completed out, no way to turn in on again.

- Some time boot stuck at busy timeout[0] 

 

 

IMG_4678.jpg

Link to comment
Share on other sites

  • Moderators

Update Lilu.kext and AppleALC.kext. It's been updated with EAPD Fix for audio after wake.

With external monitor connected, it's normal for system not to sleep with lid close, you have to select sleep from Apple Menu.

As for the screen staying blank, you might have to try injected EDID

Link to comment
Share on other sites

 Share

×
×
  • Create New...