Jump to content
PayPal donations: [email protected] ×
bg2032

[SOLVED] Optiplex 9020 USFF - screen cannot wake from sleep at all

Recommended Posts

Hello all, first post here ! This forum is a really impressive ressource. :-)

 

I have an Optiplex 9020 USFF on which I successfully installed Sierra by following Jake Lo's excellent guide, and everything seems to work as it should, except for waking up from sleep : it seems to wake up alright (produces system sounds, at least) but the screen stays dark and the only way to get back to a usable state is to turn off the machine and start it up again.

 

The config.plist from the 9020 bootpack (I used the one for A20 BIOS, even though I have the newest BIOS installed) already has darkwake=no as a boot parameter.

 

I am rather new to this, so here is exactly what I did :

 

1. Installed Sierra on a flash drive with createinstallmedia

2. Installed Clover for UEFI on the flash drive with only OsxAptioFixDrv-64

3. Merged the generic EFI + 9020 bootpacks

4. Replaced the EFI folder on the drive with the one just created

5. Rebooted into the installer and installed Sierra on the internal SSD

6. Installed Clover for UEFI on the SSD, same as (2) but with also RC scripts on target

7. Replaced the EFI folder from the SSD with the one on the flash drive

8. Copied the kexts from /EFI/Clover/Kexts/Other/LE to /Library/Extensions

9. Ran permissions.sh

10. Finally rebooted normally.

 

Seeing as the 9020 bootpack already contains SSDT.aml files, I didn't generate one.

 

As a I wrote, everything works well except that he screen doesn't wake up with the rest.

 

My specs, in any case :

 

Optiplex 9020 USFF

i5-4670S

8GB RAM

120GB SSD

 

The monitor is connected with DisplayPort and since it's a USFF model, it uses (flawlessly) the HD 4600 integrated graphics.

 

Any idea ?

 

EDIT : I upgraded to BIOS A22 and everything works now.

Share this post


Link to post
Share on other sites
27 minutes ago, Jake Lo said:

Did you set the BIOS as stated. You need Legacy Option ROMS enabled.

 

Yes, it is enabled.

 

I set the BIOS exactly as you wrote : defaults, then SATA to AHCI, set boot list to UEFI and enable legacy ROMs. Nothing else changed.

Edited by bg2032
Clarification

Share this post


Link to post
Share on other sites

Try this too

 

11. Make sure to disable hibernation as it's a prerequisite to get sleep & wake to work Ok on a Hackintosh:

sudo pmset hibernatemode 0

sudo rm -f /var/vm/sleepimage

sudo pmset hibernatefile /dev/null

Share this post


Link to post
Share on other sites

OK so apparently I was on BIOS version A21; I checked and there is a version A22, to which I upgraded. Sleep/wake works now, and I don't remember doing anything relevant in-between so maybe it's just that BIOS A21 doesn't play along.

 

Problem solved, thank you for providing the guide and ideas to solve the issue !

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...