Jump to content
flexrac

Solved-Optiplex 3050 Mojave (upgrade and issues)

Recommended Posts

Upgraded to 10.14 public beta, so far I have these issues

  • no sound (ALC255)
  • memory is reporting correct amount but about this Mac does not show the memory slots populated, it shows empty.

if you have a similar system, before you upgrade do the following

  1. back up your EFi and OS.
  2. update clover to the latest
  3. when installing clover, there is a new option to install apfsdriverloader.efi, without this, once the installation is done, you will not see your OSX drive. 
  4. if you don't want to load that driver, then you will need the latest APFS.EFI
  5. either driver needs to be installed in the Drivers64UEFI folder.

Share this post


Link to post
Share on other sites

config.plist.zip

 

@Jake Lo i had those two files in my other folder but replaced them with yours and added your arguments, audio was set to 3 from trying other methods.

still no audio.

I also did a clean install.

plist attached for review

Share this post


Link to post
Share on other sites

@Jake Lo that did the trick, but sigh, it's the same as before, audio through the front headphone port only.

Since i'm not using HDMI, i have not tested the audio.

not really a big deal but would be nice if i could figure out the rear audio, lol!

 

Thanks for your help!!!

Share this post


Link to post
Share on other sites

So I decided to attempt to upgrade this system after seeing how fast my Latitude E7250 booted up, plus I was having a issue with hd630 where it was recognized as KBL graphics and not HD630, I believe because of this I had video issues with some applications.

 

so the upgrade:

  • new power supply, I went from 180w to 240w
  • removed 7200rpm HD and upgraded to an SSD, this system does have a m.2 connection but its ssd and not pcie
  • video
    • I purchase a rx460 low profile and had to return it because I did not look inside the case prior to purchasing
    • the motherboard has the pcie slot next to the power supply allowing for single slot graphics only
  • purchased a WX3100 and installed 10.14.1 (was already on my usb stick) 
  • upgraded clover to the latest
  • install went great

now for the issues

  1. will not boot with IGPU off and disablegraphicsfirmware=true
  2. so I have to boot with igpu off and graphics firmware=false, doing this osx searches for the igpu for a long time before booting
  3. I fixed it by selecting inject ATI and radeon de init with Lilu and Whatevergreen in L/E but I don't have acceleration
  4. audio was working until I upgraded to 14.2 now I can't get it working, tried repair permission but that did not work.

all kext  loaded in L/E, no kext in clover/Other

Fakesmc, AppleALC, Lilu, whatevergreen, RealtekRTL8111

 

I'm starting to think I'm will have to sell the WX3100 and get a 4100

before I do, does anyone know of a way that I could possibly get the acceleration to work with this card?

spoof maybe? it's a Polaris card

 

config.plist.zip

 

Share this post


Link to post
Share on other sites

Update, replaced the WX3100 with an WX4100 and everything running smooth video wise.

I'm using a system def of 18,2 with inject ATI and radeonInit = true

now I have to get audio working, since I have all of my kext loaded in L/E, I'm trying to figure out how to do repairs.

 

I'm running the latest version of Mojave, some how audio was working right before updating to 10.14.3

don't know what I had did to get it working.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×