Jump to content
Mike Taylor

Can't run Windows 7 installer on UEFI *only*

Recommended Posts

Thanks for that link, I'll try to play around a bit with WinPE releases and try to use newer WinPE for Win7 than it already has.


Unfortunatelly I can't agree. The only way for me to run the installer was to enable legacy ROMs (it's still UEFI boot but with some additional legacy drivers).


I urge you to read posts #16, #17, #23 and #24 in this thread https://www.sevenforums.com/installation-setup/398482-windows-7-x64-uefi-install-even-possible-3.html#post3266108

This guy was pondering about this booting in UEFI issue and he concluded that it'll very difficult to make it working in "pure" UEFI without any grasp from legacy. 


Unfortunatelly I can't confirm that the installer runs in UEFI because the method mentioned in the link you provided is not available in WinPE v3. I'll see if I can run the installer with WinPE 5 and will come back with the results.

Share this post

Link to post
Share on other sites

Right, so conclusion of what I've been doing is as follows. 


This whole can-not-launch-in-UEFI thing must have something to do with video drivers as Engert was mentioned in the topic I linked in the previous post. 

Eventually I launched Windows 7 (WinPE 3.1) installer with Legacy ROM support (which is not the same as Legacy Boot) but I did not proceed with the installer. Instead I followed guide by @las_vegas in this thread https://osxlatitude.com/forums/topic/7813-dual-booting-any-os-x-and-windows-not-system-reserved-partition/ 

Additionally I had a problem that Windows 7 installer did not detect the USB stick it booted from but it's a well known issue that Win7 installer does not have USB 3.0/3.1 drivers so you have to add them to the WIMs.


After restarting my laptop I could boot into windows. Then I tried to go back to bios and disable legacy ROM support to see if the windows will boot. Indeed it didn't. I saw the floating windows logo which hanged in the middle but I've heard the windows welcome sound so the system itself booted but the screen hanged which again relates to the video driver issue. Thus I switched legacy ROM support back on again, booted windows, installed Intel Graphics drivers, back to BIOS, disable legacy rom support, back to windows and all worked fine. From this moment onwards I could disable any ROM legacy support in BIOS and be able to boot (via Clover) to both Windows and MacOS.


I still sustain the opinion that Windows 7 by itself does not work with pure UEFI. I don't know what INT10 (which Engert mentions in his posts) is, but even if I tried to install Windows 7 via WinPE 5.1 (which probably would work as it might have had proper video drivers for UEFI), I still wouldn't be able to boot into newly installed Windows to be able to install the graphic drivers. To sum up, I wouldn't have done it without enabling Legacy ROM support which satisfies me in 95% but my knowledge isn't good enough to do anything about it.



Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...