Jump to content

[SOLVED] E7250 - Lingering issues after successful install


rich110
 Share

Recommended Posts

Hi,

I've successfully managed to install High Sierra 10.13.6 on my E7250 (with A19 bios). I followed the Official Guide using Clover 4617 (now upgraded to 4644), and the  E5450_HS_A19.zip boot pack. I formatted the hardrive using APFS. The installation went pretty well, I even installed a DW1560 Wifi card and that works very well.

 

But... the are some remaining issues that that I'm having trouble sorting out. These include:

  1. The Clover boot menu does not automatically detect my boot drive. The hardive icon is highlighted in the boot menu but the label say something along the lines of 'boot not detected'. Funny thing is , if I hit enter then the laptop boots correctly. I've tried changing the 'Default Boot Volume' in clover but when I put in my HDDs name (Mactintosh) or the UID then the Clover boot loader doesn't even detect the drive and I need to reboot from the Clover USB.
  2. After booting, the screen goes immediately black and the power button light flashes slowly like it is in sleep mode. When I hit the power button the login screen immediately appears.
  3. The battery doesn't show the correct charge. After installation the taskbar battery icon showed only 39%, and this did not increase not matter how long the power was connected. Furthermore, if I unplug the power the battery % goes down, when I plug it in again the power doesn't increase.
  4. The brightness up/down Fn buttons on my laptop work fine, but the system does not remember the last brightness setting. After every boot I need to increase the brightness as it is always quite low. Is this normal?
  5. The CAP lock key plays up a little, I have to hit is several times to turn on and off - the number of times seems to be a little random. From what I've read in other posts, however, this seems like a know issue, correct?

 

The biggest worry is definitely the battery charging/percentage full issue, followed by the boot drive issues. Any assistance would be great.

 

I've attached my EFI folder (zipped) and a copy of my boot.log file.

 

Thanks in advance.

Cheers,

Rich

 

 

Link to comment
Share on other sites

  • Moderators

@Richard Piola

Welcome to OSXLatitude Richard.

First off, you're using the wrong files for this system. You should at least go with the closer match E7450. There's a high Sierra bootpack here

If you would prefer a bootpack for E7250, boot to Clover GUI, press F4. Now compress and attach /EFI/Clover/ACPI/Origin folder here, I'll patch the files for you.

Create a new bootpack for E7250 for you to test.

Hopefully will fix most of those issues.

The Caplock is known with the current ApplePS2Controller.kext. Tap twice to enable, then twice to disable.

Newer PS2 kext like VoodooPS2Controller by Rehabman or ApplePS2SmartTouchPad by EmlyDinesh might have the fix for it but you'll lose the touchpad or other features since they are not build for Alps. You can try Dr. Hurts kext, which is the best kexts for Alps at the moment.

Link to comment
Share on other sites

@bronxteck

Thanks very much for the quick reply. I deleted the OEM and driver64 folders from my Clover setup. I had already moved the LE contents to the Library/Extensions folder on the HDD and rewrote permissions. No change I'm afraid.

 

@Jake Lo

Thanks too for the quick response, and also the amazing packages and support you offer on the site. 

After your response I realise that I made a mistake in my original post - I think that I did indeed use the E7450 (A19) boot pack that you linked to. 

Attached is my Clover Origin folder as request. Can you pls let me know what I need to do to install the new files once you provide them?

 

Thanks again,

Richard

 

origin.zip

Link to comment
Share on other sites

  • Moderators

The origin folder is a bit of a mess with duplicate filenames. Can you clear the folder, then follow the steps again?

Post new Origin folder again.

You could try this bootpack for now for A17. Replace files into /EFI/Clover

Copy kexts in /EFI/Clover/kexts/Other/CopyToLE to /Library/Extensions

Repair permissions and rebuild cache

Link to comment
Share on other sites

Hi! I am following this to install in my dell  E7250 (i7-5600U CPU @ 2.60GHz also with A19 bios). And I am not able to run the install with your instructions.

 

The funny thing is I am able to install Mac OS X with unifail, but I have no way to make the touchpad work neither a wifi adapter that should be supported.

Link to comment
Share on other sites

 Share

×
×
  • Create New...