Jump to content

DSDT Latitude E7450


acquarius.13
 Share

Recommended Posts

Hi guys,

 

I tried to patch again following @wiking1304 step-by-step guid reported on this topic, but I still get Arg0 error. I attach some a pic (#1) about it. 

The fact is the PARSEOP_Zero Error (aggressive) does not produce any applicable patch (pic #2), so I still get Arg0 error.

Deleting it, I can compile but with a lot of warnings (pic #3). I suppose I will get the same problems (audio, brightness, bluetooth) using this patched DSDT.

 

Have you got any suggestion?

 

Thanks

 

Marco

 

 

 

Link to comment
Share on other sites

  • Replies 58
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

  • Moderators

Your model don't have the Nvidia card, so you could leave off the 1st 2 patches, required only to the Nvidia model

[01][syn] Fix PARSEOP_IF/CLOSE_PAREN Errors

[02][syn] Fix PARSEOP_ZERO Error (aggressive)

 

Warnings are fine, just need errors fixed

Link to comment
Share on other sites

  • Moderators

For that, you run this patch I wrote

Quote

 

# Fix IASL bug on some DSDT

into method label _CRS code_regex Store\s+\(Zero,\s+ECRW\s+\(If\s+\(PM0H\) replace_matched

begin

Store (Zero, ECRW) } If (PM0H)

end;

 

into method label _CRS code_regex Store\s+\(Zero,\s+F0LN\)\s+?\}\)\) replace_matched

begin

Store (Zero, F0LN)

end;

 

 

Link to comment
Share on other sites

@Jake Lo [01][syn] Fix PARSEOP_IF/CLOSE_PAREN Errors is actually your patch, which I added to my repo. 

# Fix IASL bug on some DSDT by Jake Lo
# https://osxlatitude.com/forums/topic/10375-how-to-fix-recent-dsdt-common-error-caused-by-iasl-bug/

 I also modified some of original patches and added some patches of my own in my repo, but as I wrote, that repo were intended for my personal use.

 

@acquarius.13 Jake probably thought it was something different, since his patch is not in original repo, and yes, you need to run that one first. As he wrote, you do not need [02][syn] Fix PARSEOP_ZERO Error (aggressive), since you need it only if you need to fix PARSEOP_ZERROR errors that you do not have. Do not run patches that are made to resolve errors if you do not have those errors.

 

You can use [91][syn] Fix ADBG Error (alternate) to fix ADBG error in your screenshot, or you can fix it manually. btw. I do not have that one if i use refs file when decompile.

 

If you do not have nVidia, do not run those patches with gfx0 in name (21,22,23).

 

Be sure that you are working on freshly decompiled DSL files (or clean DSL files from backup). Fix errors first. When you successfully compile, run patches one by one, and check if everything still compiles after applying each patch.

 

Have you also changed your config or just patched files folder? There is no reason for bt, audio and brightness not to work if you just changed patched files with original config.

 

For working brightness you need to have SSDT-PNLF.aml in patched folder and proper com.apple.driver.AppleBacklight patch in kextstopatch section of your config, so be sure that you have that aml in your patched folder.

Link to comment
Share on other sites

Hi guys,

 

I've tried to follow all your suggests.

Now, when I apply this patch [igpu] Rename B0D3 to HDAU <==again change layout-id to 11 before applying the patch I get the errors in the pic.

If I try to remove those methods, errors go away, but then I get KP.

If I don't use that patch, boot doesn't start at all.

I suppose I'm too incapable to solve this alone..

 

If you have more kind hints, try to give them to me. 

 

If not, it's not a problem to stop this topic

 

Thanks again a lot for your kindness

 

Marco 

 

Link to comment
Share on other sites

I downloaded origin from your first post and patched it without any problem. I am not sure how you managed to get that error. What you exactly did in order to change layout id? Can you show me the code that produce the error and what are you doing in order to fix it?

 

I have some additional remarks that doesn't have anything related to your current errors, but might be helpful. You do not need to change anything manually if you are using my repo. I made another patch [19][audio] Audio Layout 11, which change layout ID to 11 and device-type to Realtek ALC 293. I also made [17][igpu] HD 5500 graphics which sets ig-platform-id and model for Intel HD 5500. [12][sys] Fix PNOT/PPNT is needed only if you have dropped CPU SSDTs in config.

 

 

Link to comment
Share on other sites

I completely forgot that, since I fixed it in mine. Now I see where those errors came from.

 

Mine should be complete, since I also added this at the end:

into_all all code_regex PCI0\.B0D3 replaceall_matched begin PCI0.HDAU end;
into_all all label \_SB.PCI0.B0D3 set_label begin \_SB.PCI0.HDAU end;

EDIT:

 

This one should be enough, I can't remember where that second line came from.

into_all all code_regex PCI0\.B0D3 replaceall_matched begin PCI0.HDAU end;

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share


×
×
  • Create New...