Jump to content
griftopia

[SUCCESS] Latitude E6330 Mojave Upgrade with Clover

Recommended Posts

So I have 10.14 working on my E6330. Before I seek advice on my outstanding issues I will explain exactly how I upgraded in case it matters

 

I first upgraded my version of Clover and booted to a black screen. I thought I messed up Clover upgrade. Mentally readied myself for scratch install for 10.14 and proceeded to create USB stick. After I booted using USB stick I saw Clover menu item for my HD. With nothing to lose I selected HD and booted into 10.13.6 !!!

Since I now had my laptop back decided, let me see if I can fix Clover on my HD. Google search informed me later/latest version of Clover trashes OsxAptioFixDrv from the UEFI folder under CLOVER directory. Simply copied that file from my EFI backup folder, unplugged my USB and restarted. I had 10.13.6 back. 

Then I proceeded upgrade Mojave through AppStore. 1-hour later I booted into 10.14 !!!

 

Immediately saw the expected issues related to kext since I hadn't repaired permissions. Backlight/Sound etc kexts in /L/E and my bluetooth patch in /S/L/E needed to be repaired.

I looked into /L/E and to my surprise, the 3 kexts from the bootpack were still there! However IOBluetoothFamily.kext in /S/L/E was of course replaced by Mojave, so I proceeded to patch it again.

 

I repaired my kext cache (and have actually done this 3 times). Every time from the Terminal I don't get any errors and it completes with message asking me to reboot. I also see the kexts being applied in the Terminal. However it would seem /L/E and /S/L/E kexts are not being applied. I don't have sound and I don't have bluetooth. I don't think there is any step I missed, so appreciate any suggestions from those who did upgrade from AppStore like me on their latitudes.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

Sound problem with E6330 solved through below post

 

 

Bluetooth issue specific to my machine also solved by patching correctly.

 

Had to re-disable hibernation and now sleep work too!

 

E6330 with Mojave now working perfectly !

 

Share this post


Link to post
Share on other sites

Hi griftopia, I have same laptop as your's except cpu difference, I have tried many ways to let mojave to working, but finally failed, Could you share your complete EFI folder? 10x Thanks.

Share this post


Link to post
Share on other sites

Hi griftopia I have exactly the same computer but I've been trying for almost a year to get a stable and fully functional os x but never succeed, would you please share your EFI folder? You would get my eternal gratitude if you do so, knowing that you already have my respect for achieving what I failed for one year I would consider you directly as high as Luke Skywalker.

Share this post


Link to post
Share on other sites

@liaojingxi @joeleboucher

Asuming you have Low Resolution display 1366x768, give this bootpack a try.

First download this, then add the attached into /EFI/Clover

I didn't include Apple or Microsoft folder, those should be there when you first install Clover, but don't delete them

Just add the contents of EFI replacing the files

If your resolution is higher, let me know

E6330_Mojave_LoRes.zip

  • Like 1

Share this post


Link to post
Share on other sites

@joeleboucher Whatever Jake Lo says is always pure gold. Please follow his instructions.

 

PS - I've been having a perpetual problem with my osxlatitude account where I am not able to login, ask for password reset, provide new password, but then after session expires NOT able to login again. This has been going on for past few months and I don't know what to do. As soon as I'm able to get to my other laptop, will post the zip files.

 

EDIT - my efi

efi.zip

Share this post


Link to post
Share on other sites
On 11/11/2018 at 8:04 PM, Jake Lo said:

@liaojingxi @joeleboucher

Asuming you have Low Resolution display 1366x768, give this bootpack a try.

First download this, then add the attached into /EFI/Clover

I didn't include Apple or Microsoft folder, those should be there when you first install Clover, but don't delete them

Just add the contents of EFI replacing the files

If your resolution is higher, let me know

E6330_Mojave_LoRes.zip

 

Joined to say thank you for making and sharing the bootpack, with it I now have macOS Mojave 10.14.2 running in near perfection on my e6330 with A20 bios.

 

I was working on my own DSDT and everything worked fine except for the usb port on the back, I think Rehabman's series 7 usb patch wasn't enabling all the ports. I just couldn't get it to work. Got tired of trying and rebooting and I tried your bootpack and to my surprise all usb ports worked. In fact everything seemed to work just fine! All the basics like audio, graphics, networking and even the sd card! The only things that didn't work are near nitpicking level for a hackingtosh build. But I share them anyways and also also share the fix, if I managed to fix it.

 

When closing the lid the screen stayed on and going into sleep manually was a shallow sleep only. This was fixed by applying _WAK Arg0 v2 and HD4000 brightness fix patch from Rehabman's repo. The laptop now sleeps when closing the lid or entering sleep manually. The power led pulsates. This was really the biggest issue. I consider working sleep an extra for hackingtosh builds, not an essential at all. Very happy this works on top of everything else.
 

I've also experienced some weird dragging behaviour, from time to usually when dragging icons upwards the icon itself changes position, it's hard to explain and happens very rarely and is really not an issue. Sometimes after selecting stuff the selection line stays on and it keeps selecting stuff until cancel is pressed. I had this happen on very old D series builds as well from time to time. I think this was an issue with PS2 kext or something. There's also some graphical glitches when shutting down and the bootup logo has a dark background instead of light. No clue how to fix those.

 

Really not much to complain about to be honest. I'm more bummed out I couldn't get the usb on the back work in my own DTSD, I'm not even sure if it matters much to use my own extracted DTSD or the one you built. Everything works just as well as what I made and it made the usb on the back work 😃

 

Since I wasn't sure which patches were done in the bootpack I applied Rehabman's recommended patches as well. These were: HPET, SMBUS, IRQ, RTC, OS Check fixes and the Mutex with non-zero SyncLevel fix. They might already been applied by you or fixed in another way but I had them applied in the one I was working on. Not sure if any of them are needed for sleep but I really don't wanna try one by one to see which ones are needed for working sleep 😅 

 

I did also apply the HD4000 Low Resolution patch hoping it would make brightness control show up in display control panel or fix the garbled display on shutdown and weird dragging behaviour but I don't think this one is needed. The brightness controls didn't show up and graphics were working just fine without this patch applied.

 

For good measure I've attached my DTSD that I extracted and patched up myself and the modified version of the one you posted. Been using it for a few days with great results. I am really curious what in mine would cause the usb port on the back not to work, just for educational purposes haha. I've also attached a compiled version of the modified one from the bootpack just in case someone else with an e6330 wants to give it a try without the need to compile it. To make the e6330 purr all someone needs to do is follow the instructions in your post and replace the DSDT with the one from my post.

 

Thanks again for sharing!

 

On 11/12/2018 at 3:28 PM, Jake Lo said:

can you post the Kernel Panic?

Try disable/uncheck PluginType

also griftopia posted the files, try replacing with that

 

Oh yeah, this was needed to stop the panics when booting up. Not sure if all e6330 need to uncheck it but mine did.

 

PS: The e6330 might be old but it runs Mojave like a champ and it only has an older slow ssd, the i3 and 4gb of ram. Very pleased with the performance of this little monster.

 

DSDT.aml.zip

DSDT-origin-broken-usb-on-back.dsl.zip

DSDT-bootpack-modified.dsl.zip

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...