Jump to content

[SUCCESS] Latitude E6330 Mojave Upgrade with Clover


griftopia
 Share

Recommended Posts

So I have 10.14 working on my E6330. Before I seek advice on my outstanding issues I will explain exactly how I upgraded in case it matters

 

I first upgraded my version of Clover and booted to a black screen. I thought I messed up Clover upgrade. Mentally readied myself for scratch install for 10.14 and proceeded to create USB stick. After I booted using USB stick I saw Clover menu item for my HD. With nothing to lose I selected HD and booted into 10.13.6 !!!

Since I now had my laptop back decided, let me see if I can fix Clover on my HD. Google search informed me later/latest version of Clover trashes OsxAptioFixDrv from the UEFI folder under CLOVER directory. Simply copied that file from my EFI backup folder, unplugged my USB and restarted. I had 10.13.6 back. 

Then I proceeded upgrade Mojave through AppStore. 1-hour later I booted into 10.14 !!!

 

Immediately saw the expected issues related to kext since I hadn't repaired permissions. Backlight/Sound etc kexts in /L/E and my bluetooth patch in /S/L/E needed to be repaired.

I looked into /L/E and to my surprise, the 3 kexts from the bootpack were still there! However IOBluetoothFamily.kext in /S/L/E was of course replaced by Mojave, so I proceeded to patch it again.

 

I repaired my kext cache (and have actually done this 3 times). Every time from the Terminal I don't get any errors and it completes with message asking me to reboot. I also see the kexts being applied in the Terminal. However it would seem /L/E and /S/L/E kexts are not being applied. I don't have sound and I don't have bluetooth. I don't think there is any step I missed, so appreciate any suggestions from those who did upgrade from AppStore like me on their latitudes.

 

Thanks in advance.

Link to comment
Share on other sites

Hi griftopia I have exactly the same computer but I've been trying for almost a year to get a stable and fully functional os x but never succeed, would you please share your EFI folder? You would get my eternal gratitude if you do so, knowing that you already have my respect for achieving what I failed for one year I would consider you directly as high as Luke Skywalker.

Link to comment
Share on other sites

  • Moderators

@liaojingxi @joeleboucher

Asuming you have Low Resolution display 1366x768, give this bootpack a try.

First download this, then add the attached into /EFI/Clover

I didn't include Apple or Microsoft folder, those should be there when you first install Clover, but don't delete them

Just add the contents of EFI replacing the files

If your resolution is higher, let me know

E6330_Mojave_LoRes.zip

  • Like 1
Link to comment
Share on other sites

@joeleboucher Whatever Jake Lo says is always pure gold. Please follow his instructions.

 

PS - I've been having a perpetual problem with my osxlatitude account where I am not able to login, ask for password reset, provide new password, but then after session expires NOT able to login again. This has been going on for past few months and I don't know what to do. As soon as I'm able to get to my other laptop, will post the zip files.

 

EDIT - my efi

efi.zip

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...