Jump to content
punjabigator

OptiPlex 7040 - Mojave Install Help

Recommended Posts

Happy New Year OSX-Latitude folks. Jake and Bronx thanks for helping. 

 

I cannot get pass the End Randomseed. Tried several versions of OSXAPTIOFixDRv but no luck. The current EFI is attached with origin folder. I have checked the RAM as well and two chips are installed in 1 and 2 slots. 

 

Any help will be greatly appreciated. THANKS

EFI.zip

Nvidia card removed.

Jake using your config.list

Rig+Qr1%THm7qiH%0tCfDg.jpg

Share this post


Link to post
Share on other sites

Make sure you have BIOS set to load defaults, apply and then go back and set it to

  • UEFI
  • AHCI
  • Legacy Option ROMs off
  • Secure Boot off
  • CPU XD support enabled
  • Like 1

Share this post


Link to post
Share on other sites

Thanks Jake for the suggestion. I reset the bios to default and made the suggested change. I was able to pass the random seed, however, got kernel panic. A picture is attached and I need help in interpreting this panic. 

509A857A-ABE4-47F1-AC12-7843841DBFEE.jpeg

Share this post


Link to post
Share on other sites

Thanks for a quick reply Jake and I used the provided config. Although The installer stopped at the same place again, it took a little longer and many lines of codes appeared before it panicked.  Did you add fake Id for intel 0x12345678 

Share this post


Link to post
Share on other sites

you can try updating your bios to latest 1.11.1

also maybe use aptiomemoryfix.efi instead of OSXAPTIOFixDRv.

on my 7050 i use lilu and weg to support my IGPU on mojave and igp is connected via HDMI but mine has HD520 graphics as opposed to your HD530

Share this post


Link to post
Share on other sites

Thanks Bronxteck for the info. A dell technician just visited and replaced the motherboard as I was unable to install Windows on it either. However, after replacing the MB, Dell Tech suggested that the system has a bad CPU as it can boot with one RAM stick (Windows Install). The Windows 10 instal could not go through either. The Dell will replace the defective processor in coming days and that might help. In the meantime I ll keep on hold for the OSX install. Thanks all of your help

 

PS: with one RAM stick, I was able to boot with OSX_MJ installer, however, installation could not be completed after it booted second time to the installer. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×