Jump to content
PayPal donations: [email protected] ×
arcaman6

[SOLVED] E5540 Audio After Sleep Issues

Recommended Posts

I was hoping someone could help me with an issue on an E5540 regarding loss of audio after sleep.

 

The E5540 is running High Sierra and was installed using this guide and installation went fairly smoothly.  I used the  E7440_HS.zip bootpack as the E5540 does not have Nvidia (tried to rework for no Nvidia but was not able to get it working). Everything worked except SD card but fixed config and now works fine. However I don't have audio after waking from sleep - works fine (speaker and earphone) when first booted. After sleep no audio on speaker unless you plug/unplug earphones which seems to restart it - but never anything on the earphones themselves after wake.

 

I've checked bootpack kexts and seems to be OK (CodecCommander) and not sure what to do next.

 

Machine has i5-4200U cpu, HD4400 gpu, ALC 3226 audio controller.

 

Cheers and thanks in advance for your help.

 

 

debug_18128.zip

Share this post


Link to post
Share on other sites

Try rebuilding kextcache again.

run in terminal to check if CodecCommander is working properly

log show | grep CodecCommander

  • Like 1

Share this post


Link to post
Share on other sites

Thanks for the reply. I have rebuilt it countless time but the result is the same. Here is the output from the rebuild:-

 

sudo ./permission.sh

Password:

rebuilding //System/Library/PrelinkedKernels/prelinkedkernel

kext file:///Library/Extensions/DisableTurboBoostBattery.kext/ is in hash exception list, allowing to load

Kext with invalid signatured (-67062) allowed: <OSKext 0x7fba2884aaa0 [0x7fff8e37eaf0]> { URL = "CodecCommander.kext/ -- file:///Library/Extensions/", ID = "org.tw.CodecCommander" }

KernelCache ID: 79467EA040F45B7C043B1554575197F2

kextcache updated critical boot files, requesting launchd reboot

Finished

 

Every time I repeat I get the same output.

 

There is a lot of repeated information in the log so here is a relevant snippet attached.

 

I'm not familiar with this log so not sure if this says its working properly or not.

 

Cheers.

 

 

codeccommanderlog.txt.zip

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...