Jump to content
LaMosca

Newbie Questions - E7240 with i7-4600U

Recommended Posts

Dell Latitude e7240 with i7-4600U, 16GB RAM, 512GB Samsung 860 EVO, Dell DW1550 WiFi/BT card.

 

Followed all the guides as best I can to install macOS 10.4.3 (including supplement) and most all is good.

 

I have the kexts installed (I believe per the guide) to EFI/CLOVER/kexts/Other (except for CodecCommander.kext and DisableTurboBoostBattery_2.3.kext which were copied to /Library/Extensions). The trackpad works, but nearly all the time, the Trackpad Pref Pane indicates "No trackpad found."

 

One question I have after reading more, I'm wondering if some/most/all of the kexts should be moved to /Library/Extensions? This guide indicates "Copy FakeSMC and only critical kext's needed to run the MacOS Installer, Updater or Recovery to EFI/Clover/kexts/Other" - which ones are considered critical for Installer/Updater/Recovery?

 

To enable my new WiFi/BT card (Dell DW1550), I need some additional kexts (AirportBrcmFixup.kext, BrcmPatchRAM2.kext, BrcmFirmwareRepo.kext) ... these should go to /Library/Extensions, correct?

 

I'm also not sure yet if the battery indicator is correct. Is the fix for that part of the guide (and thus would already be in place if I did it correctly) or is there something additional I need to do?

 

Thanks in advance for any help/guidance.

Share this post


Link to post
Share on other sites

 

For your laptop - FakeSMC, Liu, USBports, and trackpad kexts can be in the OTHER folder. Make sure that you are using DETECT mode in the clover, which let the OSX to load Kexts from the L/E first. 

 

As the guide states all of the third party kexts should be in LE. Also use the method mentioned in the guide to install kexts rather just copy and paste.

 

 

 

Share this post


Link to post
Share on other sites

" using DETECT mode in the clover, which let the OSX to load Kexts from the L/E first. "

 

That is not completely correct.

"Detect" will only work for detecting fakesmc in L/E and if so then load. clover is hard coded to first pull from "Other" folder

best option is to use "Inject"

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...