Jump to content
Jack Doe

Dell Latitude 7490 Mojave APFS error

Recommended Posts

Greetings to all members of this great forum. I'm kindly asking for you help and expertice into solving one problem of mine. I am completly unable to install Mojave on my brand new Dell Latitude 7490 laptop (full specs down below). The computer reboots itself everytime I try. I was able to catch the error using slo-mo on my phone since everything was happening so quickly. debug=0x100 doesn't help.


For unknown reason the install is unable to convert my drive into APFS. First time I tried to install on GUID partition, then formatted the whole drive (both with Disk Utility and later with terminal). After reboot I see new drive in Clover. I'm able to boot into it and I see that "Mojave can't be installed on this computer".

I was using Jake Lo's guide on Mojave install https://osxlatitude.com/forums/topic/8506-dell-latitude-inspiron-precision-vostro-xps-clover-guide/?do=findComment&comment=87342 , his bootpack and ioncatana's clover folder from this thread https://osxlatitude.com/forums/topic/11259-dell-latitude-7490-mojave/.

 

CPU: Intel Core i7 8650U
SSD: M.2 Micron 2280 SATA
GPU: Intel UHD Graphics 620
DISPLAY: FullHD

 

error.png

Share this post


Link to post
Share on other sites

Set to Default, apply, then set SATA Operations to AHCI, set Boot List Option to UEFI, disable secure boot

When formatting drive, select GUID / Journaled Extended. 

Installation will convert it to APFS

Other had try formatting to APFS, you could try that too.

Share this post


Link to post
Share on other sites

Well the only difference I had was Legacy enabled. I followed your instructions anyway. Still facing same error. 

Previously I was reading forums about this error and one guy said that formatting to HFS or APFS with terminal would help. Not my case obviously.  :( It's not the "fixing permissions" error right? I can't figure out what's wrong. Seems like all drivers and kexts I would need are in place.

Share this post


Link to post
Share on other sites

Could you please provide a terminal screenshot from the macOS Installer after you executed "diskutil list"? Just to make sure we provide you the right commands. ;) 

 

Anyways, you can try it on your own this way...

 

1. Boot macOS Installer

2. Start terminal

3. Erase your HDD/SSD from terminal with "diskutil eraseDisk JHFS+ macOS /dev/>>YOUR-DISK-ID<<<"

4. Create a GPT partition on that disk from terminal with "diskutil partitionDisk /dev/>>>YOUR-DISK-ID<<< GPT JHFS+ macOS 0b"

5. close terminal

6. Start the macOS Installation and choos "macOS" as installation drive

 

NOTE: replace the whole ">>>YOUR-DISK-ID<<<" with a value that matches your to your system maybe "disk0" or "disk1" or whatever.

 

Share this post


Link to post
Share on other sites

Installation fails anyway. I've noticed "failed to open <private" to be latest sentence in installation log. Then I see black screen with text and reboot. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...