Jump to content

d630-intel-1440x900 Lion success


Recommended Posts

I post this to help others who have the 1440x900 display.



Core2 Duo 2.00 GHz (T7300), 2 GB RAM

Graphics: Intel GM965 / X3100 / Crestline

Display: 1440x900

Audio: ICH8 HD Audio / Sigmatel

Wifi: Intel (doesn't work. not that i'd use it though.)



Lion 10.7.2, then upgraded to 10.7.3.

Tried Xcode 2.3 and some other stuff, everything works so far.



Updated with custom D630_OSX_GMA.zip, the only one I've tried.

Later, I flashed with the standard A17 BIOS, and it works too.


BIOS settings:

Onboard Devices -- SATA operation = AHCI (I set it to ATA after install which works too)

Performance -- Dynamic Acceleration = Off

Wireless -- Internal Wi-Fi = Off (or kernel would panic)


Modify bootpack-D630-intel.zip:

NOTE: this bootpack is for 1280x800 display. Another DSDT.aml is needed for graphics to work.

Replace Extra/DSDT.aml with this one (thanks simeonoff):


Edit org.chameleon.Boot.plist:

Set graphics mode to 1440x900x32 (for VESA mode at boot)


Prepare USB install stick:

Run myHack and give it your OS X dmg and then the above modified Extra. I did this on a real Mac...


Boot from USB install stick:

Use verbose (-v) to note errors, especially what kernel extensions are involved in kernel panics. Don't worry about "IOGraphicsFamily not found" - graphics will work anyway.



Laptop keyboard worked during installation.


Reboot from USB again, select your HD partition, boot with -v


1) Install EDP package (version 2.2 in my case)

2) replace /Extra/Models/D630-intel/DSDT.aml with the one on your usb

change /Extra/Models/D630-intel/chameleon.Boot.plist to use 1440x900

3) run /Extra/edptool.command


There was some kernel panic (audio driver?) after installing drivers/fixes the first time, but never again.


PS2 controller:

After trying all PS2 controllers I went with #4 ANV-Slice Modified VoodooPS2Controller. I'm not sure which one is the best as I got inconsistent results. Trackpoint worked only with #1 Apple's PS2 controller, but way too fast. Edge scrolling worked fine at one point with #2 VoodooPS2Controller and way too slow another time. Also note that two-finger stroke isn't supported by the hardware. For best mouse wheel functioning, change scroll direction in mouse prefs (uncheck it) and set scroll speed to max.


Alt and command/logo modifiers need to be swapped on the laptop keyboard. This can be done in keyboard prefs.



Wakeup from sleep/suspend-to-ram wouldn't work with NullCPUPowerManagement.kext + SleepEnabler.kext. It works without it though, and the machine doesn't get hot.


Tested, working fine so far:

* graphics

* audio, including hardware buttons for volume and mute

* ethernet

* sleep/suspend-to-ram

* laptop keyboard and mousepad

* usb storage, keyboard and mouse

* cd/dvd reading - haven't tried burning


* Power source is always detected as being battery.

* CPU usage spikes (or worse) on battery power making everything jerky.

* After running OS X, the BIOS will do its not-so-quick scan.

* Mounted USB storage will be lost at sleep - unmount them first!

* probably more...


In conclusion OS X works very well on this machine. But archlinux rules. ;)

Link to comment
Share on other sites

  • Replies 22
  • Created
  • Last Reply

Top Posters In This Topic

Hey Bud !


Been working on my 630 with 1440x900 all day trying to get it upto 10.6.8 in readyness for Lion but with no success :-(


I have been using Simenoff's DSDT but only a standard Dell A17 BIOS. do you think the risk of flashing the BIOS to a custom one is the way to go with Simeonoff's DSDT ???


Could you post up how you got your D630 to 10.6.7 or 10.6.8 please ?


I have done the 1525 and 620 to 10.6.8 with no problems at all but this X3100 1440x900 D630 is causing me no end of pain.........


Hoping you can point me in the right direction,


Kind Regards,



Link to comment
Share on other sites

Sad to say I had no joy at all with this method and the A17 BIOS.


I tried with dynamic acceleration=ON and OFF but both ended in failure (No KP's mind) - but just a lock-up.


Loading in verbose fails at :


USBMSC Identifier (non-unique) {Loads of numbers}

0 0 AppleUSBCDC: start - initDevice failed

0 0 AppleUSBCDC: start - initDevice failed

0 0 AppleUSBCDC: start - initDevice failed


and the whole process just stops.


Maybe the key is your custom BIOS ? - Did you try this on any other occasion with the A17 BIOS Bud ?





Link to comment
Share on other sites

Been trying all ways to get this 1440x900 past 10.6.3 but with no luck Bronxy.


It's stable as anything on 10.6.3 using Simenoff's DSDT but I cant even get it to 10.6.8 let alone to Lion without major KP's yet my 620 and 1525 were easy and done in 2 hours.


I'm going to swap the Lid and LCD next week to a normal 1280x800 and fit the 1440x900 lid to my D620 and see how that goes - the 620 seems to be faster than the 630 anyway even tho it has a slower CPU so if all goes well I may even just swap my 2.5 C2D into it as well.


I currently use the Myhack method with generic kexts and boot off a CD which is custom for each model I work on and it works fine, every time. I bought a couple of new 8GB sticks to try with Lion but nothing seems to work.


I have to work today but I'll be around later and post some more see if we can't figure it out.





Link to comment
Share on other sites

I used someone else's real Mac to run myHack to put the Lion installer on a 16 GB usb stick.


I never tried the A17 BIOS (I had version 4 (!) before I flashed it with the custom bios downloaded from this site). I could try A17 now but that won't mean that the installation process should work unless I go through it again. About the risk, has the flashing failed on anyone?


BTW, if I enable dynamic acceleration the system is still stable. But again, it might be an issue during installation. Only thing I've noticed is that OS X will report a 1.8 GHz CPU instead of 2.0 GHz.


Once I got graphics working to get to the installer, it was very solid, never a crash (just once as I mentioned).

Link to comment
Share on other sites

I gave up in the end last night Bud.... I ended up switching my 1440x900 lid onto my D620 and it works without a hitch.


Which SMBIOS.plist did you use ?


The one from OSX Latitudes EDP Package ? (I tried both the one from EDP and the original one from Simenoff's boot CD mind)


Would you be able to post your Extra folder to the net so I can download it and give it another try ? - I think I have a spare 1440x900 Lid at work I can throw onto my D630 and continue testing another day when I have more time.





Link to comment
Share on other sites

Hi nac.......


I had another crack at this today.


I double checked my 8GB USB install of Lion was good by installing it onto my D620 with the 1440x900 Lid and it all worked First time (As Everything always does on the D620)


So......... I took the lid off my D620 and put it back onto my D630, used the same USB stick but with the D630 bootpack and Simenoff's DSDT and EVERY TIME it failed.


It just would not even get to the welcome screen where you put in "Use xxxx for the main language" (No Pun intended on the xxxx by the way) ;-P


After about 10 tries with various SMBIOS's I decided to go back into my A17 Dell BIOS and DISABLE EVERY SINGLE THING I COULD apart from Dualcore and ACHI.


........... Guess what ?


It's booted into the "Choose your language" screen...........


It's late here now, and I have to work tomorrow so I need to turn it all off without testing any further to find out what part of Bios is stopping it from loading the initial setup.


I'll report back tomorrow if I can find an hour or two spare at work to investigate.





Link to comment
Share on other sites

Guest ChAntoine

I'm very interesting following your trials.

I found that disabling wifi and the perf is ok to reach the installer first step. Anyway, it get an error very soon after selecting the language (while attempting to install really... Arghhhh)


Good luck and continue posting your results!

Link to comment
Share on other sites

Hate to say but still no luck at all with this and a standard A17 BIOS...... (I know the guide is written for custom BIOS but I hate to change to custom stuff as I can see people have had problems in the custom Bios forum)


SO....... I started to enable stuff back in BIOS and got to the point where everything was enabled again but still it would not boot into the installer (Keeps failing with either a KP or just locks up)


If I boot with -v -x (and everything enabled) I can get to the installer where I select the language but the best I managed was to get to about 30% of installation and then the D630 just locked up again.


If I boot in 64 bit mode the Whole boot process is EXTREMELY FAST ! - But it all fails again so is no better. (It just fails at the same point at a faster rate) hehehe


So..... I went back to trying to get it upto 10.6.8 and have actually managed to get there by using a DSDT written for the 1525 (Which I did on my 1525 just last week with no issues at all).


Honestly - the D630 with 1440x900 is a mission and a half to work with - All the others have been VERY easy compared to this one :-(


Totally lost with this one at the moment but at least I have a working 10.6.8 d630 1440x900 now which I didn't have before..........


........ every step is a small one and it looks like a looooooong road ahead LOL


Speak soon,



Link to comment
Share on other sites

  • Create New...