Jump to content

BCM4350 (DW1820A) and Apple Watch Auto Unlock feature.


Recommended Posts

So according to @Hervé's guidance, I was able to use my DW1820A. My configs were posted here.

After some research, I'm able to use Auto Unlock function now, and still no freeze, after 1 hour of usage.


A. Some research.


Model                             Typical Devices      Device ID              Auto Unlock Supports
BCM94331CSAX          MBP 2012               14e4:4331            NO
BCM943224PCIEBT2  MBA 2011               14e4:4353            NO
BCM94360CS               MBP 2013               14e4:43a0            YES
BCM94360CS2             MBA 2013               14e4:43a0            YES


It looks like by faking dw1820a(bcm4350) into 14e4:4353 will make it looks like an 2011 mba card, and won't get Auto Unlock function.

BCM433x can't use auto unlock, BCM436x can.

DW1820A was BCM4350, in between of 433X and 436X.


B. The new config.

So instead of faking the card into 14e4:4353, and setting brcmfx-driver=1, I tried 14e4,43a0 and set brcmfx-driver=2.

And that's it, nothing else changed, everything's working, including Apple Watch Auto Unlock. (It didn't work in the first place, but worked after disabling and enabling the feature again).


C. Some screenshots and terminal outputs.

a. kextstat|grep -y brcm


❯ kextstat|grep -y brcm
   38    0 0xffffff7f83b7b000 0x6000     0x6000     as.lvs1974.AirportBrcmFixup (2.0.0) E26D15A8-3484-39B1-BFE7-0BB1984A415B <37 16 13 8 6 5 3 2 1>
   91    1 0xffffff7f83d34000 0x25a000   0x25a000   com.no-one.BrcmFirmwareStore (2.2.10) FEAD3CAB-F1B9-329A-8291-EAC222EBC0F0 <6 5 3>
   92    0 0xffffff7f83f8e000 0xb000     0xb000     com.no-one.BrcmPatchRAM2 (2.2.10) EA8FADAF-E7F3-3CDF-8440-49C15C0E25F8 <91 23 6 5 3 1>
  138    0 0xffffff7f83f99000 0x835000   0x835000   com.apple.driver.AirPort.BrcmNIC (1400.1.1) 0F1637EA-51B0-3A81-9433-956A19427984 <137 136 135 16 13 8 7 6 5 3 1>

b. SysInf Wi-Fi. (firmware version changed, and the Auto Unlock line comes out)


c. SysInf BLE.( firmware version changed)



D. Some problems.

I heard some noise, maybe coil whine, after booting into the system with this new config. The noise disappeared after several minutes.

I never noticed such noise before switch to this config.

  • Like 5
Link to comment
Share on other sites

Hi, I have also DW1820A part # CN-0VW3T3, but 1028:0023.

I was able to get it to work by clover hack injecting:




it works without AirportBrcmFixup and brcmfx-driver=1.


But I want to get to work also Apple Watch unlock. Problem is, that with pci14e4,43a0 system not booting. I tried it also with AirportBrcmFixup and brcmfx-driver=2, but still no luck. With brcmfx-driver=1 system boots but it says, that WIFI HW is not present.


Did you use FixAirport and AddDTGP? I can work without this hack, because my path is <key>PciRoot(0)/Pci(0x1C,0)/Pci(0,0)</key>, but may be without this fixes pci14e4,43a0 not working? I just guessing.


Thank you for any suggestion.


BTW. I also found wifi card BCM943602CS that is newest and have 14e4:43ba, but this also not working for me.


  • Like 1
Link to comment
Share on other sites

Hello, @Naidis

My Lenovo E52-80 laptop has a DW1820A (CN-08PKF4), no pin masking...
After making the following modifications and restarting the computer, I found that the automatic unlocking function of the Apple watch in the system already exists, but it can only be unlocked once. Neither the second nor more times can the lock be successfully unlocked, just let me go to enter password. I try to the  disabling and enabling the feature again and restart, but nothing for change.

so I modifications is wrong??  or this card can't be use the "watch auto unlock" feature ??   AirportBrcmFixup.kext's BUG??


this is my Clover Configs:
Boot: brcmfx-driver = 2 , brcmfx-country=HK
Devices: compatible with pci14e4,43a0
Kexts: AirportBrcmFixup.kext,  BrcmBluetothinjector.kext, BrcmFirmwareData.kext, BrcmPatchRAM2. kext  in the Cover/Kext/Other.



thx a lot.

Link to comment
Share on other sites

Hi Naidis, is your auto unlock Apple Watch still working? I'm still trying to get mine to work. Already renamed to 14e4,43a0 and set brcmfx-driver=2 in boot args. Still cannot get the auto unlock to work. Other features are working normally such as handoff. I have the CN-0VW3T3 version.


Kexts I'm using are:







Running on Catalina, all latest version 2.0.6

Any ideas for me to try?


Link to comment
Share on other sites

  • Administrators

Latest Broadcom patching kext set is build 2.5.2. Build 2.0.6 is old now.

You should only be using Repo or Data. 1st one if you cache kexts, 2nd if you inject them through Clover.


I very recently posted about my experimentation and findings re: Bluetooth of DW1820a and those patching kexts here.

Link to comment
Share on other sites

Auto unlock only happens the first time I set it up. After waking up from sleep, auto unlock does not work anymore. To allow auto unlock with Apple Watch, change clover settings: Devices -> Properties -> compatible -> pic14e4, 43a0


Anyone have any luck allowing auto unlock with Apple Watch to work EVERY time?

Link to comment
Share on other sites

  • Create New...