Jump to content

[SOLVED] Dell Latitude 5580 - Mojave 10.14.5 (Touchpad issues)


form
 Share

Recommended Posts

Hello there!
I recently installed Mojave onto my laptop utilizing a partition so i can dual-boot windows and macOS using a single ssd.

Everything has mostly gone smooth when installing the actual macOS and the only thing i haven't still done is installing a bootloader onto the macOS partition, so i'm still booting from the clover located on my USB.
The main issue i have (Which is extremely annoying) is that the touch pad doesn't work at all. I have tried using several configs but nothing has worked. And I'm not sure that installing the bootloader onto the partition would make a difference regarding these issues I have. And thanks to me testing several clover configs, kexts and such, i recon my clover is very untidy, so I apologize in advance.


What's working:

  • Intel 630
  • Battery indicator
  • Webcam
  • Sound through speakers (Haven't tested the 3.5mm output jack yet)
  • Bluetooth (I cannot turn it off, but it detects devices)
  • Wifi (Using a external TPLink usb adapter, iirc my laptop uses a internal intel card which is a no-go)
  • USB ports everywhere
  • External Mouse
  • iMessage, iCloud, FaceTime and such services. :)

 

What's not working:

  • The actual touch pad (Unsure what brand/model it actually is)
  • The internal WiFi card
  • Mouse Pointer / "The nipple"

 

Haven't tested the SD-Card reader.

 


Any help would be highly appreciated.

Cheers 

CLOVER.zip ZxmMccSW1Qbh_debug_12469.zip

Link to comment
Share on other sites

  • Administrators

Looking at Dell's documentation, the Latitude 5580 shows fitted with an Alps TouchPad. The driver page says it's compatible with other model such as the Latitude E6x30 or E6x40 so give Dr Hurt's kexts a try.

 

Initially, I would have been tempted to say this laptop was likely fitted with an I2C TouchPad in which case I would have suggested you try the latest I2C PS2 kexts. The mouse pointer is unlikely to be supported by the I2C kexts.

https://github.com/alexandred/VoodooI2C

https://github.com/alexandred/VoodooI2C/releases

 

Intel wireless cards are not supported (you appear to know that already), so you have to replace it by a supported model or, as you currently do, use a USB dongle. We have inventories of supported/unsupported cards available in our R&D section.

 

Link to comment
Share on other sites

Thanks for the reply, I tried both suggestions but none worked. I'm not even sure if it evens loads the kexts, because i can't find any mentions of Voodoo expect the ones that says "Kext with invalid signatured (-67062) allowed".
It really does feel like Dr Hurt's kexts should've worked, but as i said, not sure if it even loads.

Link to comment
Share on other sites

Alright, i tested your suggestion but that made my keyboard stop working and sadly the touchpad is still dead :sad:

Ah forgot that i mistakenly removed the VoodooPS2Controller kext too. (Thats probably why the keyboard died). It works after re-adding it.
Windows device manager tells me that the Hardware ID of the touchpad is: ACPI\DLL07D1 , and googling that tells me that it is indeed an Alps I2C Hid device.
Feels like this should be easier then it is 😕
Cheers

Link to comment
Share on other sites

Re-Added those (IIRC those were for another dell laptop that i based my clover config from) + re-did the VoodooI2C dsdt patch. Made no difference though. 😕

I'll try around with removing / disabling those ssdt patches. But it probably won't do anything (Didn't do anything)
I'm not sure where the problem lays, if it's the in DSDT or something else.

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...