Jump to content
tweeteee

Graphics garbled WQHD Touch Lenovo X1 Carbon Gen2 (4th Gen i7) Laptop

Recommended Posts

Hi

I have a Lenovo X1 Carbon Gen2, i7-4600U Touch Screen 2560x1440 (WQHD), which I have spent about a week installing High Sierra.

I tried to follow things the recommended way and got it all working, except that when I enabled framebuffer to get QE/CI, I keep getting the garbled distortions flashing all over the screen. I can see it is accelerated and is working but its impossible to use with the display that way.
I tried all the various framebuffers for Laptops and also different SMBIOS like Air, BookPro and even iMac but with no luck. Also tried extracting the EDID withing Windows using moninfo and injected it via Clover but no change. Even tried new install of Sierra and Mojave but same problem.

Stayed up till 4am last 3 nights in row and really dont know where the issue is. I have some feelings about something to do with the display characteristics or something but no idea.

I actually got the laptop after doing one for the 3rd Gen model for a friend friend, except it was a HD 1920x0180 model, and that worked ok.

Any help much appreciated.

IMG_20190715_015311.jpg

IMG_20190715_025335.jpg

IMG_20190715_031251.jpg

IMG_20190715_031304.jpg

IMG_20190715_025331.jpg

debug_31891.zip

Share this post


Link to post
Share on other sites

Ah no it was only set temporarily during the boot I did so I could get in and get the debug files.

In the photos where it gives the problems, it is not set hence there is QE/CI (I can see the transparency and also it moves things rapidly. But the screen artifacts all over the place

Share this post


Link to post
Share on other sites

Ok, I see your IGPU is HD 4400, you'll need to add fakeID = 0x04128086

or add under Properties

device-id and data = 12040000 

Share this post


Link to post
Share on other sites

Wow that helped huge amount thank you, its progressed now  😁

The screen image is stable now, but it auto reboots afters few seconds or when I launch any graphics aspect such as CineBench.

It is definitely the graphics doing it, as when I launch with non QE/CI system is 100% stable.

Is there anything that I can check or change, or any idea what part of the framebuffer or graphics could be doing this ?

Btw is there a specific framebuffer you would recommend and is it better to use WhateverGreen or the old school IntelGraphicsFixup with CoreDisplayFixUp ?

Thank you 

Share this post


Link to post
Share on other sites

Hi Jake

 

Thank you so much, if it was not for your guidance about the device id's i would have still been going in circles.

 

I managed to fix it all. The trick was to do as you advised but also to NOT use WhateverGreen. When I used that I would get instability.

I switched back to the old way of using CoreFixUp and IntelGfxFIxup and injected a correct EDID. The EDID I had extracted was actually flaky and causing issues too. I then used DarwinDumper to extract the proper EDID and injected it. And voila !

 

🤩

Share this post


Link to post
Share on other sites

Sorry for later reply, been away from computer so busy with work. 

Yes managed to get HDMI working as well, but it was kind of a bit picky. 

Would not connect to a normal 1080P display without fiddling with the control panel display resolution.

I would for example have to choose 1600x900 and then it would pick up. But its small price to pay 😃

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...