Jump to content

E6540 - EFI - Mojave 10.14.5 working except HDMI Sound Sync with TV and Webcam


Recommended Posts

I have E6540 working almost perfectly fine with Mojave 10.14.5 except for couple of things:-


1- HDMI audio not syncing properly with TV ! I never had that issue.

2- Webcam is not working and I need it for meetings and stuff.


I have attached my fully working EFI.zip  also the clover origin dump files E6540_origin.zip and the Darwin Dump files hoping someone could assist DarwinDumper.zip


I am also wondering is it possible now to get the E6540 to work with the AMD Radeon HD 8790M instead of the Intel(R) HD Graphics 4600 but also get the HDMI working the with TV?


I'd appreciate any assistance please :) @Jake Lo


Thank you

Link to comment
Share on other sites

  • Replies 24
  • Created
  • Last Reply

Top Posters In This Topic

  • Moderators

I don't think Clover can read your SSDT's from anywhere other than just Patched folder. Can't really tell since the debug log in Misc is for another system.

Fix that and your USB might start to work or use Hackintool to help configure your USB ports.

No Optimus is still not supported in MacOS unless there's an option in the BIOS that set to only use the discrete graphics. As far as I know, it doesn't.

You have SSDT-DDGPU.aml, so obvious it'll get disabled anyway.


Link to comment
Share on other sites

Thank you for the response Jake,


I have uploaded a slightly modified EFI.zip including the preboot.log.zip


I have modified the Config.plist to point to the patched folder directory, I am still having the same problem, I can get sound from internal speakers only but there is no sound at all from the TV even though there are a number of HDM sound output options that come up when I connect the HDMI cable.


Webcam is also not working for some reason but its working on Windows 10,


External 128GBSSD used as USB as well as 2nd internal 128GB SSD drives have always been working fine on 10.15.4 without any issues.


Also I know you mentioned this point before that Clover doesn't look into subfolders within the patched folder but I believe it does, for over a year and half I've been able to alternate at boot time between different config files between E6530 and E6540.


Thank you for your help

Link to comment
Share on other sites

When I run install_tools.sh I keep getting the following error !





+       SCRIPT VERSION 4.3.3        +




+      AUTHOR: black.dragon74       +



Found script data directory at /Users/r00tdvd/Library/debugNk

EFI Mount Script (RehabMan) not found. Need to fetch it.

Checking connectivity..

Using custom test url: github.com

Unable to connect to the internet. Aborted.

Link to comment
Share on other sites

It was because I turned on the Firewall when I turned it off it worked. but now it keeps saying You forgot to press F4 but I pressed F2 & F4 and doesn't generate the files on the Desktop ! hmm, I have 2 SSD Hardrives with 2 EFI and I mounted both but still. Any ideas, I will keep rebooting to try to do it again and again but I already did it twice.


Found script data directory at /Users/r00tdvd/Library/debugNk

EFI Mount Script (RehabMan) found. No need to download.

IORegistryExplorer found at /Applications/IORegistryExplorer.app

Verifying if correct version of IORegistryExplorer is installed.

Your version of IORegistryExplorer.app passed the check. Good to go!

Patchmatic not installed. Checking in DATA directory.

Binary found in DATA directory.

Data will be dumped at /Users/r00tdvd/Desktop/14514

Dumping loaded ACPI tables.

Dumped loaded ACPI tables.

Dumping clover files.

Mounted EFI at /Volumes/EFI (credits RehabMan)

Verifying your EFI files...

You forgot to press F4 or Fn+F4 at clover boot screen.

Please reboot and press F4 or Fn+F4 to dump ACPI origin files.




Link to comment
Share on other sites


  • Create New...