Jump to content
ftrela

[SOLVED] ASUS R556L - Sleep only turns off the screen

Recommended Posts

Hi,

 

I'm running Mojave 10.14.6 on ASUS R556L laptop. I believe this is just a local model name for a bunch of laptops with X555L motherboard. I have managed to get most of the things working but I'm having problems with sleep.

 

When I press Sleep button, the only thing that actually goes to sleep is the screen. Everything else is still working (I'm able to play music using keyboard shortcuts). I am unable to turn the screen back on though.

 

Any help would be much appreciated, I have already tried numerous fixes but to no avail.

 

Edit: Forgot to mention I swapped the stock wifi card for the BCM94352HMB. 

 

debug_18656.zip

Share this post


Link to post
Share on other sites

Hi.

 

1. Remove "IntelGraphicsFixup.kext" and replace it with "WhatverGreen.kext" (Download WEG)

2. Check your hibernate status by typing the following in terminal "pmset -g | grep hibernatemode" Which mode is set?

 

Report back after you have followed the steps. :)

  • Thanks 1

Share this post


Link to post
Share on other sites

Thanks for helping me out!

1. I replaced it, it doesn't seem to make a difference regarding sleep

2. The pmset command returns 0 as the hibernate mode

Share this post


Link to post
Share on other sites

@ftrela

 

Ok, hibernate mode 0 is mostly used for desktop machines. Try "sudo pmset -a hibernatemode 3" at the terminal, reboot and see if it makes any difference. :)

Share this post


Link to post
Share on other sites

Thanks, it actually did make a difference :) After a while the fans stopped and it seems it went to sleep. I pressed a key to wake it, the fans started working again but the screen remained black, I had to force shutdown. 

 

It seems to me that the problem may be in the nvidia graphics card. I've been trying to disable it with SSDT patches but it's still present.

Share this post


Link to post
Share on other sites

Disable the rename of PEG0 to GFX0 in the Config file

It's preventing the SSDT-disableDGPU.aml from executing properly

Share this post


Link to post
Share on other sites

I completely forgot I had it... Thanks, now the Nvidia card is no longer present. Still, I'm getting black screen on wake. I've tried applying a DSDT patch for that but it didn't help.

Share this post


Link to post
Share on other sites

Apple released a "Supplemental Update" for macOS 10.14.6 just a few days ago. It includes a fix for an issue “that may prevent certain Macs from waking from sleep properly.”  ... Maybe that can fix your problem?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...