Jump to content

Dell E7240/E7440 no sound after installing Catalina


totobike
 Share

Recommended Posts

Hello everyone,

 

I have a sound problem after installing catalina beta on my dell E7240. (same as Dell E7440)

Everything works except sound and bluetooth.

 

I would like if possible to solve the problem of sound first.

 

I tried to add the kext AppleHDA_ALC292.kext in L/E, or to copy paste S / L / E AppleHDA.kext from High Sierra to S / L / E Catalina and it's still not working. After each change, I dumped kext cache and repaired partitions.

 

Thank you to the person who will help me.

Link to comment
Share on other sites

Hi ! 

Thank you for your answer, I updated again Lilu.kext in EFI and AppleALC292.kext in L/E and the sound problem is still here.

 

I don't understand because I have 3 apfs volumes, one High Sierra, one Mojave and one Catalina.

On High Sierra everything is working, on Mojave I've got no bluetooth but sound is working and on Catalina I've got no sound and no bluetooth.

I used the E7440 EFI for Mojave that you posted. 

Thank you for your hard work. 

Link to comment
Share on other sites

  • Moderators

Switch over to AppleALC.kext + Lilu.kext. Change layout-id to 12 or Hex 0xC

Remove AppleALC292 from /L/E

Disable the AppleHDA patches under kextToPatch in the Config file

Repair permissions and rebuild cache

 

Will support all the OS's

Link to comment
Share on other sites

Hi, 

  • Okay I removed AppleALC292 from L/E
  • And I am using last version of AppleALC + Lilu in EFI/CLOVER/KEXTS/OTHERS

 

Sorry I don't understand what is " layout-id " that I have to change to 12 or Hex 0xC

Is it in config.plist from my EFI folder ?

I send you a screenshot of my config.plist attached.

 

  • And I think the AppleHDA patches are already disabled. You can check on second attached screenshot.

 

Thank you for your help

Capture d’écran 2019-10-02 à 14.24.26.png

Capture d’écran 2019-10-02 à 14.29.56.png

Link to comment
Share on other sites

Thank you again for your help.

 

Now I can't boot on Catalina but I can boot on HS and Mojave. I tried to add the extra patch in my config.plist with clover configurator and still not boot on Catalina. I've got this Panic (attached picture) : "In memory panic stackshot succeeded........"

 

Do you know the origin of this problem ? I saw on internet that it was maybe from lilu.kext but everything is okay I updated it...

IMG_20191002_151126.jpg

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...