Jump to content

[Solved] USB3 not recognised on mojave 10.14.6 with an E5530


kup1
 Share

Recommended Posts

Hello, finally got a little time, and trying to get USB3 working  with my Mojave install.

Using the latest version of Mojave and followed Jake Lo's install guide.
Used the bootpack for 10.14.2 from the bottom of this page -

The install went OK and fixed the card reader by changing 1 letter in the config file, thank you for that info in the other thread.

ATM there' a few little problems, the USB3 ports are only seen as USB2, the ethernet isn't recognised, and FN+F1 shuts down the laptop.

 

Tried a few guides earlier in the week but with no joy.

Most guides where suggesting using a port limit patch (but i only have 4 usb ports) ?

Tried some different kexts for the ethernet but they also didn't work, also tried what was suggested in the other thread, but no joy.

Have uploaded my debug pack, any help would be appreciated, it would be nice to get those last few things working.1511405466_Screenshot2019-11-14at14_18_30.png.aeb9dcbc0e9f11331ccc61b6e898134d.png638475104_Screenshot2019-11-14at14_17_33.png.bfff23bd295092f15f58c6532f36c6c0.png

1010437915_Screenshot2019-11-14at14_17_03.png.66d89556165df921653bdd12da2b4503.png

debug_20338.zip

Link to comment
Share on other sites

  • Administrators

You've got no patched DSDT and, in your Clover config, you've selected ACPI patch "InjectDarwin" instead of "InjectDarwin7". The former sets the OS to Win XP when the latter sets the OS to Win7, i.e. what you need to activate USB3.0 controller support.

 

That or you patch your DSDT to simply inject DSDT alongside Windows Vista ("Windows 2006") or Windows 7 ("Windows 2009").

 

  • Thanks 1
Link to comment
Share on other sites

Hello Herve, thank you for taking the time to look at my files. Success Finally USB3 is working using Jake's download and your suggestion. Thank you.

I didn't realize/notice under the patches section there is a number 2, which takes you to page 2 and more patches, where darwin7 was.

Do i need a patched DSDT or is it OK to run without one ?

Not really fussed about the FN+F1 shutdown, but do you have any ideas about the ethernet that's not working, some of the other kexts i have tried have the correct pci ven+dev but they are not recognised.

1026016828_Screenshot2019-11-15at13_14_02.png.0482bdf7a419513aa4eba7b3c78f365d.png

 

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...