Jump to content

Dell Vostro 3446: help required to install Mojave


Recommended Posts



I have been struggling in trying to boot USB Installer.


I have Dell Vostro 3446 with:

BIOS Version is A15

Intel dual-core i3-4005U [email protected]



You can check my hardware specifications here: https://www.dell.com/support/home/in/en/inbsd1/product-support/servicetag/0-R1FvSkx3N0NROGErd1dVaGJtWEtldz090/overview

I don't have access to a Mac, so I created a Mojave bootable USB from VMware installation(High Sierra) following your Clover guide.

I couldn't download macOS from App Store for some reason (it was getting downloaded in 14-20 MBs) so I used "macOS Mojave Patcher"

I used "E6440_HD4600_Only_Mojave" bootpack but were unable to boot.

(when I disabled Nvidia card using clover options) verbose showed that it was stuck at kext stall[n] 240s


I guess I need my DSDT files patched. I tried patching but unable to.


Can anyone please help? Attaching my clover folder.


Earlier, I tried installing High Sierra in the same manner and got stuck at same point. 




Link to comment
Share on other sites

Also, I would Install HighSierra if Mojave can't work and someone can help me installing high sierra. Another thread for Installing High Sierra on the same laptop didn't work for me. I am a student video editor and hoping to run FCP on my hackintosh (If I ever get successful)


Thanks in advance

Link to comment
Share on other sites

Thank you so much for responding. 


I struggled a bit as Origin folder was not populating each time. As a fix, I used my original clover folder (attached in above post for origin files ) and combined with your patch and it worked. 


Installation went successful for me. 


Thanks a lot!!!



Link to comment
Share on other sites

  • Moderators

You don't need the Origin folder, don't see why it work with that populated. 

Did you replace just the patched folder and not Config and Kexts folder?

For audio, add CodecCommander.kext to /L/E

repair permissions and rebuild cache

  • Like 1
Link to comment
Share on other sites

Hi @Jake Lo!, Thank you so much for the support.❤️ I am sorry for not being able to reply in time and update you. 😔


I added CodecCommander.kext to /L/E and now audio works fine but strangely microphone is not working now.


On 11/24/2019 at 1:24 PM, Jake Lo said:

Did you replace just the patched folder and not Config and Kexts folder?

No, I had replaced entire CLOVER folder as far as I can remember.



Also, my trackpad is behaving inconsistently. More often it doesn't work (and it shows no trackpad) but sometimes it start working perfectly out of the blue. Sometimes, it works but behaves weirdly clicking and dragging with just a touch. E.g, at this moment I can see trackpad settings but touchpad doesn't work.


Keyboard works perfect except when I increase brightness using keyboard hotkey F12 it keeps increasing (as if it is long-pressed) until I press the brightness decrease hotkey F11. However, F11 doesn't reduce brightness whenever pressed.  



Link to comment
Share on other sites

Yes, I see brightness Icon but only for first press, after that, no.


Unable to generate debug file following the guide. It says "unable to connect to the internet. Aborted." However, the internet is working fine in Safari (I tried my both working connections Ethernet and Android) . I am posting the terminal text if it helps in understanding why I am not able to generate debug files using the script. 





Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...