Jump to content

E7470 | Stuck trying to boot install USB [SOLVED]

Joao Machado

Recommended Posts

Long time hackintosh user. I do have a Intel NUC 54250WYKH running High Sierra (can't find time to upgrade it).

First time time installing on Dell E7470.

Crash on first USB boot. Cannot get to Mac OS Installer.

Stuck on Apple logo, progress bar with a very small percentage and a functional cursor, all that after all verbose finished loading.

Tried High Sierra, Mojave and Catalina. Different USB drives. They all freeze at same moment with the same behavior.


I really avoid opening new topics if there is any other that I can follow, but could not find other one alike this problem.

Any help is appreciated.


Followed the guides at https://osxlatitude.com/forums/topic/8506-dell-latitude-inspiron-precision-vostro-xps-clover-guide and https://osxlatitude.com/forums/topic/9179-dell-latitude-e7x70-clover-uefi-only/ to the letter.


Things to note:

BIOS: 1.22.8

I did not do not set DVMT to 96MB (0x3) since all bootpacks come with Lilu and WhateverGreen .

BIOS settings: Set to Default and apply, SATA Operations = AHCI, Boot List Option to UEFI, Legacy ROM = Disabled, Secure Boot = Disabled, TPM = tried both Enabled/Disabled, Wake on LAN = Disabled, and Legacy ROM = Disabled.


Clover (release 5100) with following settings:

Install for UEFI booting only, Install Clover in the ESP, all other options to the letter .


First copied (with replace not merge) the generic bootpack EFI_v5100.zip at the first guide, and then copied over (with replace) the E7470 bootpack at the second guide, usind the appropriate pack to whatever Mac OS version I was trying to install (E7470_1.17.5_HS, E7470_Mojave and E7470_Catalina)

Just HSFPlus.efi, no VBoxHfs.efi // Just VirtualSMC.kext no SMCHelper and no FakeSMC .

Updated Lilu to 1.4.0 and WhaeverGreen to 1.3.5 .


Specs: Core i5-6600U, 8GB DDR4, Intel 520 graphics, 1440p touch screen ( ! ), 512GB LiteOn LGH-512V2G M.2 SSD (non NVMe), Broadcom DW1820A,  Intel I219-LM ethernet.


Steps considered:

Used arguments -igfxvesa and -v

Tried Clover r5070.

Post my EFI folder and my F4 dump for the Mojave try.


Any help is appreciated.

Thanks in advance.

EFI_joao.zip ACPI_origin.zip

Edited by Joao Machado
Solved issue.
  • Like 1
Link to comment
Share on other sites

  • Moderators

Remove the DW1820A card and try again. Stick with the Catalina bootpack. Most up to date but of course maybe updating some of the kexts too.

DW180A has caused issue on my E7470. Someone has success with it on E7470 but has a different ID than the one I have. So you might want to confirm which version of the DW1820a you have.

But start the install without it for now.

AppleBacklightFixup.kext is not needed anymore, you could remove that

Link to comment
Share on other sites



Jake Lo, thank you for the fast answer. You was quite right. Success!


Booted to BIOS, turned off the wireless card (Wi-Fi, Bluetooth, WAN). Sticked to Catalina.

Clover USB boot did ok. Install process did ok.

Followed all the Post install process as pointed on https://osxlatitude.com/forums/topic/8506-dell-latitude-inspiron-precision-vostro-xps-clover-guide/ .


1. Installed Clover to SSD

2. Copied EFI folder from USB to the machine SSD

3. Copied kexts from /EFI/Clover/Kexts/Other/CopytoLE to /Library/Extensions

4. Repaired permissions and rebuilt cache

5. Disabled Hibernation


Everything that was supposed is working so far, but when I turn on the wireless card again on BIOS the System got extremely slow.

Right now I'm reading BROADCOM BCM4350 CARDS UNDER HIGH SIERRA/MOJAVE/CATALINA so I can try a fix. No success so far.


Will post my findings on the appropriated thread.

Thanks again.


Link to comment
Share on other sites


  • Create New...