Jump to content

Dell E7440 macOS Catalina bluetooth, Battery status, debug generator and weak problem


Recommended Posts

I made a new installation for Dell E7440 based on the following description:



For installation I used "Clover_v2.5k_r5102" and the following Bootpack:



After installation, I did the following:

Post Install:
Kexts inside /EFI/Clover/kexts/Other/CopyToLE are to be copied to /Library/Extension
Repair permissions and rebuild cache
    sudo chmod -Rf 755 /L*/E*
    sudo chown -Rf 0:0 /L*/E*
    sudo touch -f /L*/E*
    sudo kextcache -Boot -U /


For now, it looks like almost everything works except:


- WiFi works fine, only Bluetooth doesn't.
    I tried to do it based on the descriptions, but so far it looks like it doesn't work.
    Here's what I tried:
    I have downloaded “BrcmBluetoothInjector.kext”, “BrcmFirmwareData.kext”, “BrcmPatchRAM3.kext” from the link below.


    I then copied these files to the "/EFI/CLOVER/kexts /Other/" folder and to the "/Library/Extensions/" folder, running the following commands:

    sudo chmod -Rf 755 /L*/E*
    sudo chown -Rf 0:0 /L*/E*
    sudo touch -f /L*/E*
    sudo kextcache -Boot -U /
    I restarted my computer, but I still can't see the Bluetooth device.


- Battery status is not updated
    The percentage decreases and increases as needed, but the symbol does not change depending on whether it is plugged in or not unless I restart the computer.
    It worked perfectly under Mojave.


- If I close the display, the machine goes to sleep as it should.
    Then, when I open the display, the computer starts up, but the display does not turn on unless I press a key.
    Is there a setting for this to turn on the display automatically or is it not workable?


- I wanted to attach a debug file, but unfortunately I couldn't create it.
    Here's what I tried to create:
    I downloaded the file from: https://osxlatitude.com/forums/topic/10209-how-do-i-generate-debugging-files/

    I unzipped it to the Downloads folder.
    I opened a Terminal and ran the following commands:

        chmod a+x ~/Downloads/install_tools.sh

    Unfortunately, it ends with the following error: "/Users/blasio/Downloads/install_tools.sh: line 54: gen_debug: command not found"

    Can you help me out on what's wrong?


Thank you in advance for your help!

Link to comment
Share on other sites


I did everything.

- Bluetooth works perfectly, this is solved by moving 3 kext to /S/L/E folder.

- Waking up your laptop works the way I want it to!

Thank you for your Jake!


But two things still don't work:

- Unfortunately, the battery status is still unchanged.

- Unfortunately, I still can't create the debug file. The mistake is still the same.


Can you still help with these?

Link to comment
Share on other sites

So far I have not achieved anything with battery status, but I have a bigger problem.
If I remove the "SSDT-UIAC-E7440.aml" file, when I plug in any USB device, it says "It requires a USB power supply".
But if i put it back then bluetooth is not available ... :(

Link to comment
Share on other sites


  • Create New...