Jump to content

Dell E7440 macOS Catalina bluetooth, Battery status, debug generator and weak problem


Recommended Posts

Currently, I generated "USBPorts.kext", "SSDT-EC.aml" and "SSDT-UIAC.aml" using "Hackintool.app". I have just restarted it, but so far it looks like both bluetooth and USB ports are working.

All I need to do is figure out the battery status and what to do with debug "install_tools.sh: line 54: gen_debug: command not found" ...

Link to post
Share on other sites
  • Moderators

Besides unlocking Catalina protection, you'll need this as well

Note 3: To all the users that are facing IOREG dump failures:
You need to enable the accessibility permissions for the “Terminal”. 
This privacy feature was introduced in macOS Mojave.
Open Sys Prefs > Security & Privacy > Accessibility. Look for “Terminal” and allow access. 

Have you tried switching to VirtualSMC and SMCBatteryManager?

You can try VoodooBatterySMC?

Link to post
Share on other sites

I opened "install_tools.sh
"file, I looked at the directories you're using and finally realized that Catalina protection should be turned off so it works.

Unfortunately, I couldn't find SMCBatteryManager.kext anywhere, so I couldn't give it a try.
Otherwise, if I delete VirtualSMC, it will not boot.
I tried VoodooBatterySMC instead of "ACPIBatteryManager.kext" but it made almost no difference. Maybe just that with "ACPIBatteryManager.kext" I can't manually update the battery status icon, only restarting helps, but with "VoodooBatterySMC" if I turn the percentage display off and on then the icon changes.

Link to post
Share on other sites

Dear Jake,
Your expertise seems to have been successful.
Battery feedback works perfectly!
Thank you very much for your help.
Currently, I did this:
"/EFI/CLOVER/drivers/UEFI/SMCHelper.efi" deleted
"/EFI/CLOVER/kexts/Other/ACPIBatteryManager.kext" deleted
"/EFI/CLOVER/kexts/Other/FakeSMC.kext" was deleted
"/EFI/CLOVER/drivers/UEFI/VirtualSmc.efi" copied
"/EFI/CLOVER/kexts/Other/SMCBatteryManager.kext" copied
"/EFI/CLOVER/kexts/Other/VirtualSMC.kext" copied

But in addition, the downloaded VirtualSMC package contained 3 kexts:
"SMCLightSensor.kext", "SMCProcessor.kext", "SMCSuperIO.kext"
Do I not have to do anything with these? Shouldn't I use these?

Once again, thank you very much for all your help so far !!!

Link to post
Share on other sites
×
×
  • Create New...