Jump to content
durian

E6440 macOS Catalina 10.15.3

Recommended Posts

My E6440 has been running flawlessly using the installation guide here.  Is it worth it to upgrade to 10.15.4 ?  Also I have question regarding the clover package to use.  There seems to be two providers.

 

https://github.com/Dids/clover-builder/releases 

https://github.com/CloverHackyColor/CloverBootloader/releases

 

The install guide uses 'Dids'. But the last version from 'dids' is r5103.  The latest seems to be r5107

 

Thank you for any pointers.

 

 

Share this post


Link to post
Share on other sites

You'll need to upgrade to v5107 so use the CloverHackyColor version.

It lacks the HFSPlus.efi, but you can continue using the version you have currently.

Don't forget to update Lilu.kext, whatevergreen.kext and AppleALC.kext prior.

Share this post


Link to post
Share on other sites

On such older systems, you can actually retain Clover r5103 and it'll work good. I found that r5107 is only required for more recent systems such as Kaby Lake and later.

 

My old Core2Duo Vostro200 desktop runs 10.15.4 Ok with Clover r5093 and my Ivy Bridge E6230 runs 10.15.4 with Clover r5103. I proceeded with straight updates without changing anything, other than reverting to old fashioned AICPUPM on the E6230 since the XCPM Clover patch needs revisting for 10.15.4. I updated Clover to r5107 on my Kaby Lake R 7490 alongside refreshing Lilu to v1.4.2 and WEG to v1.3.7.

 

So far, I've identified that 2 x patches require updates for Catalina 10.15.4:

  • XCPM patch (for Ivy Bridge platforms as an alternative to AICPUPM)
  • AppleRTC patch

 

Share this post


Link to post
Share on other sites

Hi Herve,

 

Thank you for the pointer.  What are the steps for reverting to AICPUPM ?  Do I need to do that on the E6440.  I want to upgrade to 10.5.4 but am afraid to mess up the current setup.  

 

Thank you

Share this post


Link to post
Share on other sites

AICPUPM patch only applies to Sandy Bridge and Ivy Bridge platforms. You have a Haswell platform and that requires KernelPm patch.

Share this post


Link to post
Share on other sites

Hi Herve,

 

With my current setup 10.5.3 from the guide here, how can I safely update to 10.5.4 without messing my install ?  Is there any steps that I can follow.

 

Thank you

Share this post


Link to post
Share on other sites

×
×
  • Create New...