Jump to content

[Solved] Dell Latitude E7240 + BCM20702A0 Catalina 10.15.3


Daemoen
 Share

Recommended Posts

I've gotten sooo close.  I was initially able to get clover installed and running, but then struggled with 2 items:  Trackpad (wasn't listed at all under system preferences) and Bluetooth.  I was able to track down a bootpack from another user's post (pafkata) on here

 

This got me really really close to a perfect setup... Unfortunately, I *still* cannot seem to get my bluetooth working.  I know for sure that it does work in linux, as I deliberately ran Fedora 31 live to get the pci and usb information just to be sure I had it all correct.  The following is part of the information from lsusb:

 

  Bus 001 Device 003: ID 0a5c:21fb Broadcom Corp.
  iManufacturer           1 Broadcom Corp
  iProduct                2 BCM20702A0

I can see the device listed under USB Hub in system_information, but bluetooth says nothing found, as does pci.

 

I have the following kext's setup:

  /C/E/E/k/O
  AirportBrcmFixup.kext 2.0.6
  BrcmFirwareData.kext 2.5.1
  USBPorts_E7440.kext

  /L/E
  BrcmBluetoothInjector.kext 2.5.1
  BrcmPatchRAM3.kext 2.5.1

At this point, not sure what is missing, or what I need to change.  I had started with just the bootpack from the above post, it didnt quite work, and started to try to 'hack it together' from there.

 

Any pointers or suggestions greatly appreciated.

 

Thanks

Link to comment
Share on other sites

I just installed my Broadcom BCM94352HMB, (DW1550) last night on my E7440 Catalina. Did it exactly as Jake Lo advised in another post thatI found using the search engine...

 

IO80211Family.kext from Sierra in S/L/E. and BrcmBluetoothInjector.kext, BrcmFirmwareData.kext, and BrcmPatchRAM3 in Clover kext.

 

 

 

 

Link to comment
Share on other sites

WOOT!!!!  TYVM Jake!  I had tried nearly every permutation possible, but I also didn't realize that everything should go in /C/k/O (the github page makes it sound like either location works -- that doesn't 'appear' to be the case though).  Really appreciate it.  I've actually been pretty surprised by how stable it's been as well (aside from the two issues i had to get past).

 

This ones solved!

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...