Jump to content

Latitude E5440: fine-tuning macOS Catalina installation


Recommended Posts

I've found a UEFI ready for e5440. I've used it and I'm now typing from my catalina e5440 (sharing my android network via bluetooth)


I'm still booting via pendrive because I don't know exactly which version of clover should I be using. All the ones I tried told me that this version of macOS is not supported. Any ideas?


Also, the trackpad kinda works, but it's really bad, it only moves the cursor with a big surface are touching it, like my thumb or so.


Last but not least, my wifi is not working. I've found a post that someone made it work, but I'm not sure how.

I trying to use that guy kexts, but  ' don't really know the process to change mines I've installled some of his kext via kext wizard, than udated the permissions and cache. However, nothing happened. Not sure if because I'm booting via pen drive still. Ah, I've put them under the kext folder of the pendrive as well. but it didn't work


Looks like I'm almost there, my first working installation yay

Link to comment
Share on other sites

  • Moderators

What wifi does it have?

Intel is not supported. Need to be replace with a supported device. See here

My recommendation is go with a Broadcom chipset, Atheros has been dropped.


For Clover install the latest 5104 / 5103. You'll encounter the message that it's not supported, Just select install anyway.

After that, copy the files from you USB EFI over.

Link to comment
Share on other sites

Yeah, its a intel :(
I will replace it asap. 


About the clover, I did it :DDD Followed the guide that was mentioned in this thread (here), replaced the uefi folder and used kext utility to install all the kexts presents in the uefi folder. 


Seems to be working 99%, sometimes when booting, I got a prohibit symbol, not sure why. It's fixed trying again or selection the preboot partition in clover instead of the "normal" one. 


The only true thing thats getting me mad is the trackpad. All my kext are 












Am I missing something that could potentially fix the prohibition (using -v, it shows that the read file command returned 0x07 and the boot failed due to this)

And/or fix the bad movement of the trackpad? I mean, it's working, but looks like it's really not sensitive (not in speed), if I gentle swipe my finger in it, it doenst move the cursor at all, but if I increase the contact area, it works fine (if I swipe my finger on it's side or push a finger harder into it)


Link to comment
Share on other sites

Should I use that usbInjectAll? I got them from some youtube video, the guy had the efi/kexts ready for all Exx40 ready, sounded good for me haha

To replace a kext, it's simply changing them in the efi/clover folder and putting them under /system/extensions....? 

One additional thing I've noticed right now, there's no way to reduce the screen brigthness, my eyes are burniiiiingggg ahhaha

Link to comment
Share on other sites

@gengstapo Yes, its made via createinstallmedia. About the kexts, I'm not sure how new they are, I dont even know if I'm using exactly the ones I should. I've just followed some internet tutorial. But it took me much further then the previous time I've tried to do it


@Jake Lo
I'm using the e5440_10.15_high_res_intel.zip (uefi/clover folder) found elsewhere [NB: link removed].

Link to comment
Share on other sites

  • Moderators

Hmm, those files look like from some of my bootpacks, even down to the directory structure like  /EFI/Clover/kext/Other/LE. I have since changed it to /E/C/kexts/Other/CopyToLE.

USB_injector.kext from his files is from Hervé's E6440 guide, so it might not be suitable for the E5440.


Here, replace the attached contents into /EFI/Clover overwriting the old


Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...