Jump to content

E6530 nVidia: Goes to sleep after apple logo appears


Recommended Posts

PC Specs:

E6530 | I5 3230M | AR9281 | 8GB | 850EVO | HD 4000 & NVS 5200M |

Boot Args: keepsyms=1 debug=0x100 -xcpm -v nv_disable=1

HD4000 FakeID 0x0 | HD4000 I GplatformID 0x01660004

Latest WhateverGreen, Lilu. Latest Clover. ACPI taken from [E6430 Full Solution]

My EFI: EFI.zip

Laptops shuts the screen off when apple logo appear. I can wake the screen by pressing Fn+Brightness but it goes to sleep back after like 20 seconds. And if i wake it from Sleep it works Normal. Full HD4000 Acceleration and QE/CI support 1.5GB. I Thinks that is ACPI Error but that happens to all E6x30 Acpi's that is found on internet


It is hard to explain, i just post the private youtube video


I Can just keep using it like this but that is annoying

Which kext or what changes i have to make to Config.plist in order to achieve an enjoyable MacOS Usage?

Thanks for wasting your time

Link to comment
Share on other sites

  • Moderators

DSDT/SSDT is wrong for your system which is causing your issue. Also get rid of AppleACPIPlatform.kext. 

Boot to Clover, press F4. Continue booting to OS X. Mount EFI partition

Compress and attach /EFI/Clover/Origin folder here for patching.

What version of BIOS are you running?

Link to comment
Share on other sites

well, i have nv_disable=1 argument. I think you could Guess that i have nvidia. btw thank you so much for your effort.


I tried your Config.plist and i am getting graphics error IOConsoleUsers. Should i restore my confog.plist?

tried your ACPI without combining, tried to combine my ACPI with your and there is something. It takes 3 minutes to sleep my laptop, but after i wake it up, mac freezes

Link to comment
Share on other sites

  • Administrators

What do you mean "tried them right now and nothing [...]"?


If all you did was copy your dumped tables in the ACPI/patched folder, that's totally useless. In case you ignored this, all bootloaders do load tables from BIOS as they are... ACPI/patched folder is used for patched tables as its name implies...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...