Jump to content
PayPal donations: [email protected] ×
ace3

[SUCCESS] Dell Optiplex 3070 MFF 10.15.6 Catalina OpenCore

Recommended Posts

Hi Jake,

 

i tried your config file , replace file, and doing clean snapshot.

The result is: still no sound from HDMI, no Audio Out detected.

what changed is , my Intel UHD 630 memory change from 1536 MB to ±2048 MB

 

Here, i attached the result of my IORegistryExplorer file.

 

thanks.

 

Ignasius’s iMac.zip

Share this post


Link to post
Share on other sites

Hello,

 

i tried your new config.plist, but still no HDMI audio detected.

 

 

the new logging is attached

 

-Open Core Log

-IORegistryExplorer

 

I don't see HDAU on IO. maybe it's what causing audio failed to load?

or maybe because of Intel FrameBuffer Patching ?

 

thanks.

 

logging-25-july-2020.zip

Screen Shot 2020-07-25 at 09.41.00.png

Share this post


Link to post
Share on other sites

IOReg file is not reflecting the changes made from the Config file. You either booting from a different source or you need to select 'Reset NVRam' during boot to update the changes. There's no HDAU for Skylake system and up.

At OC boot screen, if you don't see the option, then press spacebar. That should show the Reset NVRam option. Select that, it'll go through a quick reboot.

Then boot regularly.

 

Is the current display connected via HDMI or DP?

  • Like 1

Share this post


Link to post
Share on other sites

Hi,

tried to doing Reset NVRam, but still no luck.

 

Currently i'm using DP Port, since using HDMI, no signal, just blank.

 

thanks.

 

Share this post


Link to post
Share on other sites

Hello Jake,

Good news, i try to re-apply the config.plist you attach, but the difference is i don't do OC Clean Snapshot , but reboot the computer, do the NVRam.

Before doing the NVRam restart, there is some missing ACPI, but, after the NVRam Restart, the Audio is now working.

 

I don't realize that the Optiplex 3070 Micro have an internal Speaker, and now it's working too.

The DP Audio is working too.

 

edit:

i changed the layout-id for the Realtek audio to 11.

Internal Audio OK - HDMI OK - Universal Audio Jack OK - Line Out OK

 

Thanks, one step closer to almost perfect build.

The last thing is the HDMI.

At the bios, HDMI is working, at the opencore logging/gibberish, it's still working, but at the OSX Login Screen, HDMI have no signal.

 

But i can live with the DP Port.

I read that the Next versions of Lilu and WhateverGreen should restore HDMI output capability in Catalina.

 

 

Learning from the changes on the config.plist. I have some Question.

1.There is some different in the SSDT-HPET from mine & yours, is it what causing the Realtek Audio Not working ? or the order of ACPI that causing it ?

2.The difference in HPET _CRS to XCRS Rename , mine have Table Signature 00000000 , your empty, or it's related to #1?

3.My DeviceProperties have missing mapping PciRoot(0x0)/Pci(0x1b,0x0) , does not exist, but exist in PciRoot(0x0)/Pci(0x1f,0x3) ?

4.You added framebuffer-con*-busid and other atributes, is it what called Framebuffer Patching ?

 

 

I updated the EFI on my first post, so other people can use it too.

 

Thanks.

😀

 

Ignasius’s iMac New2.zip

Share this post


Link to post
Share on other sites

The Config I'd attach already have layout-id changed to 11. The reason it wasn't working before as I had said above was that you need to select Reset NVRam after each change /update. That's why the IOREg you attached after replacing the Config and adding the SSDT-HPET did not reflect. Anyway, glad it's working now.

 

The HDMI port issue, what is the resolution of the display?

If it's 4k, you might have to increase the DVMT pre-alloc.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...