Jump to content

Precision M6700: USB ports not working at full USB3.0 speed


Neo_1979
 Share

Recommended Posts

Hello all, I have a problem with intel usb 3.0 ports.

My laptop is a Dell Mobile Workstation M6700:

cpu i7-3940xm extreme
qm77 chipset
24gb ram ddr3 1600mhz
nvidia quadro k3000m 2gb gdrr5 (I use this as my video card, optimus disabled in bios)
17,3" fullhd 1920x1080
ssd1 samsung 850 250gb (windows 10 os)
ssd2 crucial mx300 525gb (downloads)
ssd3 crucial mx300 750gb (caddy) (data and virtual machines)
ssd4 lite-on msata 256gb (sierra mac os)

5 usb ports:
2 usb 2.0 (work flowlessly)
1 usb/eSata combo port (work flowlessly)
2 usb 3.0 intel ports (work as 2.0 ports)

I can't figure it out to make 3.0 ports work at their full speed. Tried usbinjectall.kext and clover port limit patch for sierra (and rename ehc1 to eh01.....), nothing.
Tried dsdt.amd patching with 7-series/8-series usb, nothing (this method worked for other 2 laptops)
Tried fakepciid.kext + fakepciid_xhcimux.kext, nothing.
They always work as 2.0 ports. In profiler there are 2 usb 2.0 controllers ehci. Not an XHCI is shown/found.

Hope you can give me some advice to fix the problem.

Link to comment
Share on other sites

  • Administrators

In all likelyhood, your DSDT needs patching to support USB3. Check if and where you define OSYS according to "Darwin" OS detection, if at all. You need something like this

 

Best thing to do is what JaleLo suggested: post a zipped copy of your Clover folder (without the Themes subfolder). Or better, follow this.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...