Jump to content

Latitude E7440 - Wi-Fi stopped working


Recommended Posts

A while back, I used Clover to install macOS Mojave on my Dell Latitude E7440. I installed an AzureWave AW-CE123H card (BCM94352HMB chip) for wireless. Everything was working great.


But Wi-Fi stopped working, perhaps after (my stupidity) allowing an OS upgrade from 10.14.? to ?+1. (Bluetooth stopped working as well.)


So I bought another AzureWave AW-CE123H Wi-Fi card, thinking that the hardware might have failed. No dice. But otherwise, the computer continues to work well (I just use Ethernet when I want the internet).


I had always wanted to play with OpenCore, so I installed Catalina using Jake Lo's OC 0.6.0 EFI files (https://osxlatitude.com/forums/topic/13155-solved-e7440-no-usb-port-working-with-opencore/?_fromLogin=1)


Wireless still doesn't work. Symptoms are:


  • System Preferences:Network Sidebar shows "Wi-Fi off" with a red dot.
    •  I click "Turn Wi-Fi On" and the "Network Name" popup flashes, but remains set to 'Wi-Fi Off"
    •  Click the "Advanced" button, Wi-Fi tab shows one of the local SSIDs, but no connection is made
  • System Report app
    • Bluetooth "No information found"
    • Network:Wi-Fi - see below
  • On the off-chance that the wireless card had "worked loose", I removed and re-installed it. Mechanically, everything looks fine.


My question: How could I debug this? What other information could I collect? Many thanks!


System Report for Wi-Fi:

Software Versions:
  CoreWLAN: 13.0 ((null))
  CoreWLANKit: 13.0 ((null))
  Menu Extra: 13.0 ((null))
  System Information: 12.0 (1355)
  IO80211 Family: 12.0 (1200.12.2b1)
  Diagnostics: 1.0 (910)
  AirPort Utility: Not Installed


  Card Type: AirPort Extreme  (0x14E4, 0x2B23)
  Firmware Version: Broadcom BCM43xx 1.0 ( AirPortDriverBrcmNIC-1435.3)
  MAC Address: 40:e2:30:42:88:d8
  Locale: FCC
  Country Code: US
  Supported PHY Modes: 802.11 a/b/g/n/ac
  Supported Channels: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 132, 136, 140, 144, 149, 153, 157, 161, 165
  AirDrop: Supported
  AirDrop Channel: 0
  Auto Unlock: Supported
  Status: Off


Link to comment
Share on other sites

  • Administrators

A little Search on the forum would have avoided you all that hassle and expenditure, do think of using the facility in the future...


BCM4352 is not supported OOB and requires either a DSDT patch or a kext patch or device id faking or direct property injection in order to make it work. The easiest thing to do is inject a compatibility statement with BCM4360 (14e4:43a0) in the bootloader config against the relevant and previously identified ACPI/IOReg device. All details are available in our R&D->Wireless and Bluetooth forum section (inventories, dedicated threads).


You probably had patched or replaced the AirPortBrcm4360 PlugIn kext of IO80211Family in /S/L/E prior to your last update and that got replaced with a vanilla version after the update. That's to be expected. Hence why /S/L/E should always remain full vanilla in favour of alternatives (properties injection, kext installation in /L/E, etc.). Only you could tell what you had...


Link to comment
Share on other sites


  • Create New...