Jump to content

EDP 2.2 post install issue


Mr A.
 Share

Recommended Posts

Hi everyone,

i am new to the site and to the hackintosh community.

I found OSXLatitude by chance while looking for ways to install Lion.

Thanks to the installation tools available here I managed to install a bootable Lion on my D630

(so far unsuccessful with other method such as unifail). Thank you all for your work !

I am not yet understanding all technical terms and kext thingies but trying hard.

 

I have identified a problem, or maybe this is normal please let me know what you think:

 

After booting on the new install I ran Chameleon and EDP 2.2, all good, the partition boots without the usb pen.

I then run edpcommand in extra and launched the build which installs successfuly but then a grayish screen tells me in several languages to switch off and restart!

 

Looks like it comes with the trackpad driver option:

First attemp tried option 3, restarting screen happens and trackpad doesnt work

second attempt after a clean reinstall, tried option 1, restarting screen happens again, i restarted and it booted properly but trackpad doesnt work.

so cant do anything, didnt have a usb mouse with me so couldnt try to run edp with other option yet.

 

both time i answered Yes to the kext installation questions.

 

maybe this is normal but as the edpcommand says to press enter to go back to main menu at the end of the process i thought it was wrong that the OS freezes and asks for restart.

 

any suggestion??

thanks

Mr A.

Link to comment
Share on other sites

  • Administrators

Hi Mr. A,

 

First of all let me welcome you to osx latitude. We hope your stay here will be a pleasant one! :)

 

Did you use myhack 3 to prepare the usb installer?

 

If you did, after installing and configuring EDP you'll need to run myfix from myhack in full mode. After that you can reboot and it should work fine.

 

Cheers!

Link to comment
Share on other sites

Hi thanks for replying,

I used my hack 3.1, the latest I found on myhack site.

 

After installing and configuring edp there is I think a kernel panic, codes fill half of the screen and the restart message appears, keyboard and trackpad don't work. Cant do anything. Same thing after restart. Tried with external mouse and keyboard, but nothing. So I can't run my fix from the hard drive.

 

I restarted and booted from the USB pen and tuned my fix but it didn't help, on restart from the hard disk the edp command tool is still on and no keyboard mouse work.

Had to reinstall this morning.

Keyboard works fine except for a few key inverted and the laptop trackpad works just fine after clean install.

I just installed chameleon but not edp.

 

Is there a way to install just the sound independently ? Sigmatel 950 I think

And speedstep kept and the other one that edp installs ?

 

I don't know how to install kext though.

 

Hope you can help

Link to comment
Share on other sites

Forgot to say that my core 2 duo 2Ghz is recognized as a 1,09Ghz ???

 

I found on another site a mention about a kernel kext drop utility which would install kext files automatically, any good ?

Also how about th sleeping problem ? Didn't recover from dim display

 

Thanks for helping

Link to comment
Share on other sites

  • Administrators

Hi Mr. A,

 

You need to install EDP to get all those items you mentioned working.

 

After you've got the KP after installing EDP, did you tried to boot with mach_kernel arch=i386 -v -f to see what is causing the KP?

 

If we can home in on the kext that is causing the KP, we can remedy or remove it while leaving others in tact.

 

As for your cpu speed, you can disable dynamic acceleration in bios for it to show the correct cpu speed.

 

If you would like to install individual kext from the EDP, you can copy it and repair permission manually or use gui app like kext helper, kext wized, etc.

 

Cheers!

Link to comment
Share on other sites

I will try and get a shot of the screen I get after installing edp to post it tomorrow.

Once it happens i have to restart, then there is not KP, the system boots fine but no mouse nor keyboard work so can't do anything, even with external (I connect ps2 keyboard and mouse with USB adapter though)

 

I ll run the command you suggested but as system starts fine I guess it is useless.

Hope you ll see what causes the problem with the screenshot tomorrow,

Thanks

Link to comment
Share on other sites

hi,

 

here are the photos of the screen after set up of edp, then after restart (KP), then after verbose boot.

not good enough to understand this

just need to get the internal touchpad and keyboard to work and the sound and sort the sleep/dim dispal thing that makes the system freeze.

 

i got a program on osxdailay called kext drop, claims to installkext easy,

just need the kext for my system now.

 

couldyou indicate links maybe ???

BTW tried with edp 2.1 and had similar problems

in fact the touchpad will move but when i click the menu opens and closes right away i cant choose or launch anything. then once edp is installed and set up i get the screens attached.

 

hope you can help

 

PS. CPU speed sorted as you advised by disabling dynamic accelaration

post-5003-079917900 1337607853_thumb.jpgpost-5003-024251200 1337607888_thumb.jpgpost-5003-065137200 1337607912_thumb.jpg

Link to comment
Share on other sites

 Share

×
×
  • Create New...