Jump to content

[Solved] Latitude 3400: unable to install Big Sur


Recommended Posts

Hello guys! I'm trying to install BS on an external hard drive but I'm stuck in the following situation: I start the installation without any problems using the EFI folder provided by Tanya, then the notebook restarts and I select the option for the disk I'm installing macOS on to continue the process, however the machine restarts again instead of loading the codes on the screen, when it starts again it loads the codes and falls into the macOS Catalina installation screen. I already have Catalina installed on my main SSD. I thank anyone who can help me.

Link to comment
Share on other sites

I managed to solve the problem I mentioned above by formatting my disk in APFS format.

I completed the installation successfully. I also solved the touchpad problem. But I was unable to activate the brightness control.


So we have working:
Intel Graphics UHD 620
HDMI with audio
Display Port via USB-C
Audio with sound control on hot keys
Integrated Camera
Integrated microphone
Integrated keyboard
Trackpad with gestures
All USB ports


Does not work:
brightness control by shortcut keys


I will leave my EFI folder attached. If anyone can help me with the brightness control by the shortcut key I will be grateful.


Link to comment
Share on other sites

  • Administrators

Re: brightness control, you should have it as long as you inject the SSDT-PNLF ACPI table. By default, the expected keyboard shortcuts won't work (but other key combinations will) until you add the SSDT-BRT6 ACPI table that was developed by Jake Lo as an alternative to DSDT patching (as described in my E6230 or 7490 guide for instance). You can look it up through a forum Search.


Re: wireless, it all depends on the card fitted to your laptop. We've no crystall ball... Consult our R&D->Wireless section and its inventories for guidance.

Link to comment
Share on other sites

Thanks for answering! I'll follow your tip for brightness control. About wifi, I already knew that my card is not compatible. So I asked for help with brightness control only.


I just checked that I have the SSDT-PNLF and SSDT-BRT6 injected. but the hotkey does not respond. Do you have any other tips?


Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...