Jump to content

Dell Latitude E5270: OpenCore First Boot Failure macOS Catalina


Recommended Posts

Ok Jack, herebelow the situation:

WiFi

I didn't install anything immediately after the first boot. I studied how to fix the issue and read somewhere to install AirportItlwm.kext and Heliport.app. The app does nothing and if I try to load the kext at the frst boot the system goes into a panic state. The attempt was made saving the kext in the relevant folder EFI/OC/kext and setting up properly the config.plist file.

I'll give a try loading in the same way the suggested alternative Itlwm.kext.

HDMI

I see a second monitor but cannot use it (black 4k display) if I connect the cable to the port. If I boot with the display already connected, I have a lot of laptop display black out with restart from systemn login (as if I had suspended the MBP). Lastly at the end of the boot I have not enough time to type the password and the display remains black so I have to power off the MBP.

As required, I send attache the ioreg with connected HDMI cable.

VGA appeared on the other monitor for some moments, but this is not important, it isn't really necessary.

POWER

I cannot do anything by preference pane. Battery charge is declared zero%. I can only set duration for monitor standby and have no icon in the tool bar.

 

@AppleCross

I confirm I used the unmodified EFI suggested by Jack Lo in this thread. Obviously after the boot I change SMBIOS parameters and switched to OC 0.6.5 with no troubles.

 

 

MBP HDMI Rommy.ioreg.zip

Excuse my double posting, but it's only to give an update concerning WiFi: with the last driver itlwm.kext I'm able to connect and navigate with my wifi networks 2.4 GHz and 5GHz.

This connection is named in preference pan: Ethernet2. Is this correct?

 

A short update concerning monitors: for my last reboot I kept 3 monitors connected: on board, VGA and HDMI. All appear in pref pane. Now I'm using VGA (1024x768). Black screen on the others. I have to investigate furthermore

Bye

 

 

Link to post
Share on other sites
  • Replies 27
  • Created
  • Last Reply

Top Posters In This Topic

  • Moderators

@rommy

Looks like I forgot to enable the Battery kext->Fixed

Added Fn+F11 and Fn+F12 to control Brightness

I'm not seeing any external display connected in the IOReg file-> made some changes to the Config file. Moved HDMI to connector2

Replace Config with the attached and add the 2 SSDT's to ACPI

 

By the way, the name is Jake, not Jack

 

FixBattery.zip

Link to post
Share on other sites

Hi Jake (I apologize having mislead you name), due to your suggestions things have greatly improved, so, first of all, I thank you again.

 

Battery seems ok now and its configuration is allowed. Also statistics seem to work correctly.

Monitors: I have activated 2 connections: VGA and HDMI. As I already stated, I can work with VGA monitor (1366x1024) but both integrated and HDMI monitor (4k) are black. With significant delay the desktop appears on the integrated display, optimized for the resolution of the VGA monitor. Sometimes it  becomes black and it appears again. Very slow memory with 3 displays. I detached the HD monitor and now things are better but not optimal (blinking screens). I cannot extend desktop to 3 or at least 2 monitors. I see al 3 in prefs pane, but the only working option is monitor duplication. Obviously Air Play is not active. Maybe it is a limitation of GPU chipset. I don't know.

Bluetooth: I discovered I could not connect any device so I installed new drivers to simulate Broadcom device (IntelBluetoothFirmware and IntelBluetoothInjector). Now my AirPods connect and work. Associated with WiFi, in any case, BT does not allow Handoff.

USB: I noticed I cannot use all the ports, I wanted to setup with Hackintool creating USBmap.kext. I can discover two out the three accessible on the laptop (the SS USB port on the left in not activated). Is it an effect of your SSDT-UIAC.asl file? How can I add this port? See my current configuration. I have to perform some other tests with the docking station that allows much more USB ports to be exploited.

Furthermore, can the SD card on the right be made accessible in the same way?

 

bye

 

 

USB 2021-01-11.png

Link to post
Share on other sites
  • Moderators

Disable SSDT-UIAC.aml, enable XhciPortLimit under Kernel/Quirks. Reboot and you should have all ports enable. Then use Hackintool to generate your SSDT-UIAC or USBPort.kext

Yes, you need IntelBluetoothFirmware and IntelBluetoothInjector for your Intel Bluetooth, they are not native to MacOS.

SD Card reader should already be working, kext is already installed and showing in the IOReg file, but the device won't show under card reader in sys Info. Once you insert the sdcard, it should mount it to the desktop.

As for external display, try connecting only the HDMI monitor. If internal display goes dark, close the display util it sleeps, then wake it up. LCD should come up now. It's a workaround.

I don't know if HDMI can handle the 4k display, you might have to increase the DVMT pre-alloc in BIOS. 

Air play? Read the FAQ for Intel wifi feature. Basically you need to replace the Intel for a supported Broadcom wifi /BT device

 

Link to post
Share on other sites

Finally USB, BT and WiFi troubles have been fixed with the known limitations of non-Apple machines. I can also read the SD card appearing on the desktop as a normal USB key.

I'm writing using an USB keyboard, much more comfortable.

Some issues remain related to HDMI. I'm using three displays, but the only working are integrated and VGA. I discovered that now Big Sur considers it as a Display Port but it works. Monitor management by MacOS is very poor compared to what you can do in Windows10, but that's another discussion.

For me it's ok to use VGA and HD monitor with the laptop display closed, so I'm investigating on how to increase video memory to make both work together. With Hackintool I get some info about VRAM and framebuffer I summarize in the attached pictures.

I read max stolen 172 MB and stolen 58 MB. This last should comparable to DVMT I cannot modify in the BIOS. I would like to increase the parameter StolenMemorySize in order to reach the requested value of max stole (say to reach 192 MB). Is it correct if I compute 192-64=128 MB as a new size of StolenMemorySize to input in config.plist? This should correspond to framebuffer.stolenmem at the new value of 134217728 (11024x1024x128). This should replace the current value 00003001.

Am I crazy? Hope my brainstorm is clear enough.

Any suggestion or correction?

Framebuffer2.png

Framebuffer1.png

VRAM.png

Link to post
Share on other sites
  • Moderators

Have you confirmed if the HDMI port is working...say on a monitor with lower resolution before going that route?

I don't know it that actually increase it or only patches it to bypass the check. If you really want to increase it, you can use the shell to increase the value in the BIOS.

Look up my guide on how to increase DVMT pre-allocation, use the search facility

 

Link to post
Share on other sites

HDMI works on a Samsung TV monitor 22" not HD. I can setup resolution and refresh frequency and duplicate or share desktop. Every functionality is allowed.

So I think the problem is memory to allocate associated to HD features of main monitor (IPS 27") and its refresh rate (I can arrive up to 165 Hz). 

I found a thread named [Deprecated] Changing DVMT values in BIOS. Is this you refer to? Is it still valid? I have to boot a WINPE iso and modify directly the BIOS. Can I set up DVMT 192 MB or do I have to limit to 64 MB? If it depends on physical device I cannot set any value.

I'm really doubtful...

Link to post
Share on other sites

Before modding the BIOS I performed further tests browsing various sites.

I noticed that Hackintool can generate patches concerning HDMI (Patch/Patch/Advanced) so I tried to setup also the audio configuration in OpenCore config file. So I tried a couple of new Device Properties:

PciRoot(0x0)/Pci(0x1F,0x3) - Referred to audio. Initially missing

PciRoot(0x0)/Pci(0x2,0x0) - referred to Video - New data and strings with respect to original version of config.plist

PciRoot(0x0)/Pci(0x1b,0x0) - referred to ??? - Unuseful since has no data. I guess it can be erased.

See attached picture (Config hangs.png) with details

 

With the new scheme, boot hangs at a progress of about 50%

I changed the PciRoot(0x0)/Pci(0x2,0x0) restoring the original version and now I have HD video and audio with some issues: video every now and then disappears (black out lasting 5 to 10 seconds) and audio level of the HD monitor cannot be adjusted with the slider. Many progresses have been done!

See attached picture (Config ok.png) with details

Thank you

Config ok.png

Config hangs.png

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...