Jump to content

Lenovo Z70-80: Fixes for Big Sur 11.1 OpenCore


Recommended Posts

Hello to someone and ins special to who can read this post. I'm a user more in this little world of hackintosh. I use this kind of modding devices since 2007 with my fist machine one Intel Core 2 Quad and motherboard Intel pure too. Anyway, I'm not a programmer user and less an expert of swift code or similar but I can read and understand certain codes. In this case I updated my Lenovo laptop after two years. Before I was running Mojave with more less problems but running with Clover. Currently, I installed Big Sur reading and following tutorials from Dortania web and others from YouTube and forums to get my own method. My Lenovo laptop has the next specs.


Specification & Funtcionalities


- BIOS (MOD) I unlocked my FW UEFI BIOS years ago with help bios-mode web and a special took to read and flash my IC Chip. I did this to change DVMT and disable Geforce integrated video manually because with clover options it did not work

- CPU: Intel Core i5-5500U Broadwell

- Memory: 2x 8GB DDR3 1600Mhz (removable slots)

- Harddrive: 1x 2TB SATA

- Display: 17" non-touch 1920x1080 IPS, anti-glare 

- GPU: Intel Graphics 5500 (works almost perfect with patch generated by Hackintool)

- Camera: 1x 720p HD Camera & Mic incorporated

- WLAN: Broadcom native wireless card (changed with adapter)  

- Touchpad: Synaptics (works with ApplePS2SmartTouchpad.kext, with many functions like dragging to move objects and windows, tap to clic, right menu options with 3 tap fingers, show LaunchPad with 3 tap fingers down,

    swipe right and left with 2 fingers, open link in another tab with 2 fingers clic on link)

- Audio: Conexant CX20751 (works almost perfect with patch generated by Hackintool)

- 1 x USB 3.0 & 2 x USB 2.0 (works with patch info extracted and generared by Hackintool) It was aml files and USBPorts.kext

- MicroSD card reader Realtek (do not works but is detected with USBPorts.kext and aml files generared by Hackintool)

- Headphone / mic combo (works fine)

- HDMI 1.4 OutPut Port (works almost perfect with patch generated by Hackintool)

- VGA OutPut Port (works perfect with patch generated by Hackintool)

- RJ45 Gigabit Ethernet works with Realtek Kext

Restart and Turn Off (Works with OC kext to patch taken from another post on web from lenovo laptop)

- Battery Status (Works with SMCBatteryManager.kext and VirtualSMC.kext)


This publication is to request help to improve my system since I have been using a combination of methods to solve it and they have not worked for me.


If you can read lines above TouchPad works but pref pane show nothing options




Reading different post on web I could understand that maybe my problem is about a patch of energy and a special kext to patch and works fine finally but I'm not a programmer and I can't to get or create that info like I gotten using hackintool to fix video, sound and usb port. Hours ago I read on Reddit  in a post about all functionality on a laptop and the man had mentioned that is recommended declare all HW on OpenCore to do work, but I'm not programmer and I don't know how to get that info like I got it from Hackintool to fix video, sound, and in this oportunity to fix TrackPad because it show blank options


PD1. I attached my EFI folder to be reviewed.

PD2. Maybe @Jake Lo if read this post could you help me. I read your post of Lenovo T490 and I like it.



Link to comment
Share on other sites

I have not SMBus TrackPad like You can see in this pictures


image.png.35005734c31bdcacafef7dc6b2cfc3ff.png     image.png.6fa5527f6f2c85e92d8070d7fa2af71a.png


image.png.d16a1adae7c0fbdaddf7b7f4a555cbf9.png     image.png.ebabe7a42036967a4f9bc96fdd7aba00.png         


Weeks ago I read this guide in Dortania web, is similar info like my touchpad, but I don't know how to apply it




Another info relative that I found was this



But I don't know how to apply it too.





Link to comment
Share on other sites

  • Moderators

You'll need to be using the VoodooPS2Controller by Acidanthera. Have you tried switching to his kext?

See if it makes a difference. 

Can't use VoodooSMBUS since you're touchpad is not SMBus based.


Have you tried rebooting a few times?

Sometimes it just need to be cached.

Link to comment
Share on other sites

Hello again @Jake Lo, I have tried this VoodooPS2Controller but not quite because it couldn't be tapped to click. I had to enable the correct option. On the other hand I have not dragging options and phisical buttons on touchpad disabled. I've been looking those options to enable into Info.plist file but nothing. Could You tell me how to do it?







Buttons disabled and no dragging using VoodooPS2Controller



I would like to do works another Fn keys on my keyboard. Do You think that is possible? like you do it with your Lenovo T490 with native functions like on windows OS.






Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...