Jump to content

Connector patching for UHD 630 and i5-8400H or HDMI no signal


Go to solution Solved by valetzyzy,

Recommended Posts

Hey I have Dell Latitude 5591 (Dell 0F4TD7) with Intel UHD 630 and core i5-8400H (exactly H, mobile CPU) and able to get working my GPU (see screenshot), but the only problem is that no HDMI signal for external monitor.

Tried to patch every device-id that Hackintool provides, some of them causes system crash, some of them nothing changed. 

Also tried with inject intel in my clover, still the same.

Can you guys push me in right direction to able my HDMI working.

Here is my EFI folder (sorry for the mess inside, this is the only config that working) https://drive.google.com/file/d/14kcxjIlTkhaMRB7l2lqC0lXvEE-DdNp4/view

Why not OpenCore? Because I'm not able even start install of MacOS.  

 

P.S - this is the only one GPU in my laptop, so I need native support on it

ar1wb9uhkei61.png

Screenshot 2021-02-20 at 11.15.10 AM.png

Link to post
Share on other sites
  • Solution

Thank you, I get it working

with gdpmod=vit9696 boot argument

with SMBIOS MacBookPro15,2 (was MacBookPro15,1)

and Index 1, BusID: 0x01, Pipe: 18, Flags: 0x00000187 in connectors in Hackintool 

 

@Jake Lo - thanks ❤️

 

Link to post
Share on other sites
  • Administrators

Index 1 would be con0.

I'm a little surprised with stated BusId 1 and Pipe 18 as there is no such native thing in any CFL framebuffer layouts, nor in any KBL or ABL layouts.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...