Jump to content

Latitude E5440: HDMI Audio and touchpad not working in Catalina [Opencore]


Recommended Posts


Can you guys help me setting up the HDMI Audio? It's kinda frustrating to use AirPlay when it's laggy 90% of the time.

I searched on every forum, but all info out there is either old or set up for Clover. I tried "converting" Clover plist entries to match with OC plist, and I always end with panic/ broken kexts/ not booting in general. 

My latest hope was to patch using Hackintool, and even that didn't work. Config.plist entries from that patch are still in config.plist file attached.


For my second issue. I used Jake's config file from to enable the trackpad, but on every restart (or nvram reset, I don't know) it rolls back to normal mouse functionality. It is not recognized by the system anymore (blank in System preferences)




*Internal speakers are working just fine. 

**I don't know if debug file is needed here. Last time I tried, it gave me some restrictions prior to generating it. 












Link to comment
Share on other sites

  • Administrators

Please note that HDMI audio for Haswell iGPU normally requires:

  1. renaming of ACPI device B0D3 to HDAU
  2. injecting hda-gfx property to ACPI devices HDEF/HDA/IGPU, set to "onboard-1"
  3. injecting HDMI connector type 00080000 to HDMI output port/connector (usually con1)
  4. injection pipe value 0x12 to HDMI connector to 12 (or system will crash on HDMI cable plugging/unplugging)

Check what you have in IOReg to begin with and adjust your bootloader config accordingly afterwards.

Link to comment
Share on other sites

JakeLo, wow! I don't know how you did it and what you changed, the audio is working flawlessly. 

Perhaps changes mentioned by Hervé were implemented in the config and no further actions are required now. Right?


The trackpad is still blank just like in this post. I used that config file to make it working, as mentioned above. 

Is it a good idea to remove all Voodoo kexts and start over? Does SSDTs play a role in keyboard/mouse/trackpad functionality? (sorry it's my first build)


Link to comment
Share on other sites

  • Moderators

1 and 2 are handled by Whatevergreen and AppleALC

I just enable HDMI on Con2 as Herve mentioned on #3, actually the config already has con1 enable for HDMI, but I guess for your system it's on con2. I guess Con1 is VGA

4 is already enable in the Config otherwise your system wouldn't already rebooted when you plug in the cable.


Link to comment
Share on other sites

  • Create New...