Jump to content

m6800 noise from wired/wireless headphones


Recommended Posts

Anyone having a issue with static noise with headphones on m6800? I am on latest big sur, 11.2.3. In case of wired headphones (jack) there is no sound at all, only noise is coming out. With wireless headphones (bluetooth) is better but sound is stuttering. 

What I tried till now:

- AppleALC is must have for working sound (internal speakers no problem at all)

- put Codeccommander into L/E did not fix the problem (repaired permission and rebuilt cache didn't help, still noise)

- I found fix on the internet - jack fix and hda-verb in bin folder together with Codeccommander in S/L/E but I can't confirm that one.

After I get access to root files I did all of this but I can't boot into the system anymore. I am stuck with Apple logo. I will probably need to reinstall big sur again. Below are instructions that I used to enable write acces. How can I fix boot problem? Please help

 

Link to post
Share on other sites
  • Moderators

It's a bad idea to install to /S/L/E

Follow the post installation instruction from here for Alc_fix. Known issue for ALC292, so this fix will work on your system too.

You might have to disable SIP, and enable write access.

 

Link to post
Share on other sites

Thanks Jake for instructions. You're right I have to enable write access but till now I was not successful. I am on latest big sur 11.2.3. Can you please send me some instructions how to do it. What I have found on the internet wasn't working for me. Thank you in advance 

Link to post
Share on other sites
  • Moderators

boot to Recovery Mode

Disable SIP

Boot back to MacOS

Enable write access, instruction found in FAQ

run the ALC_Fix command

Boot back to Recovery mode

Enable SIP

 

Link to post
Share on other sites
  • Moderators

did you boot to Recovery Mode

Disable SIP first?

csrutil disable

and run this in terminal after reboot from recovery mode

csrutil status //to confirm if SIP is disabled

sudo mount -uw /

sudo killall Finder

sudo spctl --master-disable //only need to be ran once

cd ~/Downloads/alc_fix //assuming it's in download folder

./install

Link to post
Share on other sites

csrutil was disabled all the time via config (FF0F0000)

 

what helped for me was I went to usr-local and create bin folder. After that I put manually inside ALCPlugFix and hda-verb, restart a PC and wired headphones now work perfectly👌  

 

1. usr-local-bin -> ALCPluxFix and had-verb

2. EFI boot-OC-kexts -> codeccommander 

 

--------

wireless headphones still have this stuttering sound which is related probably to bluetooth functionality (AC 7260). I found out If headphones are near PC sound is OK but immediately when distancing from PC sound is stuttering again 

Link to post
Share on other sites
  • Moderators

Yeah, Intel wifi/ BT is still Beta. Switch to Broadcom or use a real card with adapter for better support

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...