Jump to content

Upgrading a D620 from 10.7.3 to 10.7.4... Fail!


The Vegetator
 Share

Recommended Posts

Hi All,

 

I hope someone can help as my D620 (NVidia, 1440x900) is close to being thrown out of the window.

 

Last year I setup OSX with the help of the wonderful EDP and have had no issues at all, it has been a dream. Then along came 10.7.4... I have tried everything I can think of to update it, but it just refuses to boot. I have a recovery disk that I use to get back running but I really need to update.

 

Installation of myHacks with 10.7.3 kills it, myFix doesn't help.

Installation of EDP 3 still does not help (version 3.44 tried)

Upgrade of Chameleon does not fix.

I've tried every boot flag that Google could find.

 

The fault is always the same, it stops at:-

 

Console 1024 x 768 @ 0xd0000000

 

 

My question - has anyone actually succeeded in upgrading a D620 (NVidia) to 10.7.4 and, if so, HOW???

 

I hope I'm being really daft.

 

Thanks all!

Link to comment
Share on other sites

There's a known issue. Look here: https://osxlatitude.com/index.php?/topic/1533-guide-getting-1074-and-1075-to-work-on-supported-models/

 

I'm about to try the upgrade myself on a similar D620 ([email protected]), so will report soon on the matter.

 

 

Hmm... I tried that too...

 

Good luck and let me know how you get on.

 

Thanks for the quick reply.

Link to comment
Share on other sites

  • Administrators

So far, it's not good:

 

1) I replaced the 10.7.4 AppleACPIPlatform.kext with that of the above thread (it's a 10.6.7 kext) in S/L/E.

-> The OS would not reboot afterwards, I got KP. I tried various flags ('-v -f UseKernelCache=No' or just '-v') but no change

 

2) I replaced the 10.7.4 AppleACPIPlatform.kext with a backup version of my original 10.7.2 in S/L/E.

-> The OS loads to completion (booting with '-v -f UseKernelCache=No' flags/options) but then gets stuck with a SpeedStep emulator update offer on screen. I can move the mouse, but clicks & keyboard are not operational.

 

Next step is to try with a 10.6.8 kext, but all my troubles could be due to the fact that I still have to re-run EDP and myHack Fix since the upgrade to 10.7.4.

 

To be continued...

Link to comment
Share on other sites

  • Administrators

Mmm... same result with 10.6.8 kext as with 10.7.2 version (booting with '-v -f UseKernelCache=No' flags/options). I have this PStateMenu automatic update popup in the middle of the screen and system is unresponsive although the mouse moves.

 

I did not mention this yet, but both CPU cores go superhigh and disk activity seems permanent. It's as if something heavy was cooking in the background. :(

 

But, but, but... if you wait several long long minutes, you get the hand again. :)

 

So, I think I could probably get back to the 10.7.2 kext safely enough. But I'm definitely running 10.7.4 now, yes !!!

 

D620_10.7.4.jpg

 

After approximately 20-30minutes, the system goes quiet again...

 

Off to re-run EDP and myFix Full now.

Link to comment
Share on other sites

  • Administrators

This is starting to look like a dragging monologue... :P

 

Having completed EDP and myFix re-run, I can now confirm successful and apparent stable upgrade to Lion 10.7.4.

 

The issues/annoyances I notice:

1) it now takes over 3min30s to boot into Lion 10.7.4 and about 25s to turn it off (in comparison, it takes about 50s to boot with SL 10.6.8 and 5s to turn it off). I don't think that can be totally explained by the fact that I have SL 10.6.8 on an internal SATA 5400rpm HDD whilst Lion is on an external USB-attached IDE 4200rpm HDD.

 

2) not necessarily a Lion issue but possibly a D620 one: the screen switches off after a few minutes idle (before computer goes to sleep). The trouble is it stays dark grey when I try to wake it and the only way to recover from that is to put the laptop to sleep and then wake it up.

 

Anyway, that's today's contribution...

Link to comment
Share on other sites

  • Administrators

I had no direct Internet access on the D620 (I was at work - busy obviously cool.gif ), so I actually used EDP 2.2 copied from a Windows PC. I used the following kexts of Option 5:
- Voodoo PS2 Controller
- NullCPUPowerManagement
- SleepEnabler
- Emulated SpeedStep

followed by the following fixes:
- Disable hibernation
- Touch S/L/E

I ran myFix Full afterwards before (dreaded) reboot.

I'm hesitating with EDP 3.1 at the moment because I lose sound and/or keyboard when I install the kexts. I haven't found the right combination yet, but the default/recommended kexts give me issues. I know it's a matter of trial and error, but I'll give that a rest for a wee while.

Link to comment
Share on other sites

 Share

×
×
  • Create New...