Jump to content

Latitude 7410: Big Sur - help needed


dodox
 Share

Recommended Posts

 

I was able to install Big Sur 11.3.1 on a Latitude 7410.

Notice: If the installation hangs / the computer completely freezes it is very likely that the hard disk is not supported - you need to switch it out!

 

Status: Incomplete / work needed

 

 

GPU (seems to work)

Touchpad (no multitouch -> switch to I2C needed)

WLAN (sometimes won't connect and need to be toggled on / off)

Audio (Output / Input)

Bluetooth (connected to keyboard successfully)

? Sleep

? USB (seems to cause micro system hangs?? anyone an idea?)

? Thunderbolt

 

 

 

 

#############################################################

#############################################################

#############################################################

 

Dell Latitude 7410

Big Sur

Status: Not working + no working config found

 

I am trying to get Big Sur installed on a Dell Latitude 7410.

I am able to get to the installer and to start the the install but at 16min it is completely freezing (mouse not moving - no kernel panic).

Installers last step is: Extracting /Volumes/Shared Support/com_apple_MobileAsset_MacSoftwareUpdate/36615...

 

Any ideas?

 

Edit: WhateverGreen is disabled in config. No change when enabled.

 

 

 

OC_5_23_05_2021.7z

Link to comment
Share on other sites

  • Replies 20
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

  • Administrators

Ok, so Comet Lake platform with Intel UHD Graphics for 10th gen CPUs, i.e. UHD 620, not HD 520 which is a Skylake iGPU. Of course, you need to enable WhateverGreen to obtain graphics acceleration; don't disable it.

 

Which version of OC are you using? Remove/disable XhciPortLimit quirk, that'll cause problems.

 

I recommend you follow the Dortania's guidance for CML/UHD620 laptops as you're clearly missing some essential settings in your config. For instance, if you do inject the correct graphics framebuffer layout, you're not injecting fake id 0x3E9B as is expected.

https://dortania.github.io/OpenCore-Install-Guide/config-laptop.plist/coffee-lake-plus.html

 

Link to comment
Share on other sites

openCore: REL 069 2021 05 03  so latest version.

 

Removed XhciPortLimit but no change - still freezing 😕

1 hour ago, Hervé said:

I recommend you follow the Dortania's guidance for CML/UHD620 laptops as you're clearly missing some essential settings in your config. For instance, if you do inject the correct graphics framebuffer layout, you're not injecting fake id 0x3E9B as is expected.

https://dortania.github.io/OpenCore-Install-Guide/config-laptop.plist/coffee-lake-plus.html

 

 

Thank you. Ive already followed this guide this morning. All it does is it results in a kernel panic.. Switched to MacBookPro16,1 with no change..

 

Edit: Ive noticed that device-id is something different that the platform id! Tested with device-id but still in both configs (config from the guide -> KP; my config -> no change) seems to be not working.

Link to comment
Share on other sites

Small (or big?) sucess. It freezes because of the SSD! Ive attached an external USB3 SSD and it sucessfully installed it on the drive..

 

Problem: Freezing of the installation

Cause: NVME SSD (AHCI in BIOS)

Solution: Unknown yet.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share


×
×
  • Create New...