Jump to content

E5550: keyboard recognition problem


denkteich
 Share

Recommended Posts

  • Moderators

@denkteich

I had to add a German keyboard to do this since I have a US keyboard.

So this is how to switch to ISO keyboard with ApplePS2Controller.kext

Open Keyboard preference, under Keyboard, enable Show keyboard and emoji viewers in menu bar

In the menu bar, click on the keyboard and emoji viewer icon and select Show Keyboard viewer

Now in Keyboard Preference, select Change Keyboard Type, click continue

Now instead of using your actual keyboard, you use the virtual keyboard to select the key right / left of shift key using your mouse to click it

You should now be able to select  ISO keyboard.

If you look at the virtual keyboard, you still don't see the <> key, so just press any key, the <>will appear.

german.pnggerman2.png

I don't have a German keyboard, but I think this should work after selecting ISO keyboard. Hope this helps.

 

 

Link to comment
Share on other sites

Hi Jake,

 

thx for the tip, but it didn't work.

I pressed the < key and it looks like the keyboard is recognized.

I started Testest, the key is still dead.

After this I wanted to try it again, but the "Change Keyboard Type" button is not there anymore.

 

Any suggestion how to get the button back or start the assistant manually?

 

cheers

.d

Link to comment
Share on other sites

No luck.

 

After switching back and forth, the button came back. I pressed the button, nothing happened, no assistant came up.

After closing the system settings and reopening it, the button was gone again.

 

Is there any plist that can be edited?

Can the assistant be started manually?

Link to comment
Share on other sites

 Share

×
×
  • Create New...